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Exchange services cannot be started, and event ID 7024 is logged after you install Symantec Mail Security on a Windows Server 2008-based computer that is running Exchange Server 2007


View products that this article applies to.

Symptoms

After you install Symantec Mail Security on a Windows Server 2008-based computer that is running Microsoft Exchange Server 2007, Exchange services cannot be started. Additionally, the Exchange Active Directory Topology Service fails, and the following event error is logged in the System log:

Log Name: System
Source: Service Control Manager
Event ID: 7024
Task Category: None
Level: Error
Keywords: Classic
Description:
The Microsoft Exchange Active Directory Topology Service service terminated with service-specific error 2147942414 (0x8007000E).

Note When this issue occurs, you cannot resolve this issue by uninstalling Symantec Mail Security. You may also notice that you cannot clear the Application log events.

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Cause

This issue occurs because Symantec Mail Security modifies the following registry subkey to write event logs only for Symantec applications:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\CustomSD
Therefore, when Exchange services tries to log events in the event log, Exchange services receives an "access denied" error message, and Exchange services cannot be started.

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Resolution

To resolve this issue, upgrade to Symantec Mail Security for Microsoft Exchange version 6.06. This version of Symantec Mail Security for Microsoft Exchange includes full support for Windows 2008.

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More information

For more information about the CustomSD registry subkey, click the following article number to view the article in the Microsoft Knowledge Base:
323076 How to set event log security locally or by using Group Policy in Windows Server 2003
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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References

For more information, visit the following Symantec Web sites: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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Keywords: KB954204, kbprb, kbtshoot, kbexpertiseinter

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Article Info
Article ID : 954204
Revision : 2
Created on : 2/20/2009
Published on : 2/20/2009
Exists online : False
Views : 408