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Multiple Exchange Server 2007 services do not start when you upgrade a computer that is also running Windows Server 2003 to Windows Server 2008


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Symptoms

Consider the following scenario. Microsoft Exchange Server 2007 is running on a computer that is also running Windows Server 2003. You upgrade the computer to Windows Server 2008.

Note This kind of upgrade is known as an "in-place" upgrade.

Then, you restart the computer.

In this scenario, multiple Exchange Server 2007 services may not start. These services include but are not limited to the following services:
  • Microsoft Exchange System Attendant
  • Microsoft Exchange Information Store
  • Microsoft Exchange Service Host
  • Microsoft Exchange Transport
  • Microsoft Exchange Anti-spam Update
  • Microsoft Exchange File Distribution
  • Microsoft Exchange Mail Submission
  • Microsoft Exchange Search Indexer
  • Microsoft Exchange Replication Service
  • Microsoft Search (Exchange)
Additionally, the following events may be logged in the System log:

Log Name: System
Source: Service Control Manager
Event ID: 7003
Task Category: None
Level: Error
Description: The Microsoft Exchange Information Store service depends the following service: NtLmSsp. This service might not be installed.

Log Name: System
Source: Service Control Manager
Event ID: 7003
Task Category: None
Level: Error
Description: The Microsoft Exchange System Attendant service depends the following service: NtLmSsp. This service might not be installed.

Log Name: System
Source: Service Control Manager
Event ID: 7009
Task Category: None
Level: Error
Description: A timeout was reached (30000 milliseconds) while waiting for the Microsoft Exchange Anti-spam Update service to connect.

Log Name: System
Source: Service Control Manager
Event ID: 7000
Task Category: None
Level: Error
Description: The Microsoft Exchange Anti-spam Update service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion.

Log Name: System
Source: Service Control Manager
Event ID: 7031
Task Category: None
Level: Error
Description: The Microsoft Exchange Service Host service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 0 milliseconds: Restart the service.

Additionally, the following events may be logged in the Application log:

Log Name: Application
Source: MSExchangeFDS
Event ID: 1015
Task Category: General
Level: Error
Description: Process MSExchangeFDS.exe (PID=2100). Failed to read property Path from metabase object IIS://server1.contoso.com/W3SVC/1/ROOT/OAB. OAB synchronization suspended.

Log Name: Application
Source: MSExchange System Attendant Mailbox
Event ID: 4001
Task Category: General
Level: Error
Description: A transient failure has occurred. The problem may resolve itself in a while. The service will retry in 56 seconds.
Diagnostic information: Cannot open mailbox /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=SERVER1/cn=Microsoft System Attendant. Microsoft.Exchange.Data.Storage.ConnectionFailedTransientException: Cannot open mailbox /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=SERVER1/cn=Microsoft System Attendant. ---> Microsoft.Mapi.MapiExceptionNetworkError: MapiExceptionNetworkError: Unable to make connection to the server. (hr=0x80040115, ec=-2147221227)

Log Name: Application
Source: MSExchange Common
Event ID: 4999
Task Category: General
Level: Error
Description: Watson report about to be sent to dw20.exe for process id: 3076, with parameters: E12, c-RTL-AMD64, 08.01.0177.003, edgetransport, unknown, M.E.D.D.S.SmtpSendConnectorConfigSchema.cctor, S.IO.FileNotFoundException, c9c4, unknown. ErrorReportingEnabled: False

Log Name: Application
Source: MSExchange TransportService
Event ID: 1016
Task Category: ProcessManager
Level: Error
Description: The worker process crashes continuously on startup: C:\Program Files\Microsoft\Exchange Server\Bin\edgetransport.exe. The service will be stopped.

Additionally, you may experience the following symptoms:
  • When you try to open the Exchange Management Console, it does not open. Additionally, you receive the following error message:
    MMC could not create the snap-in. The snap-in might not have been installed correctly. Name: Exchange Server 2007 CLSID: FX: {76dd58f7-54ba-42e3-a2e0-dbf4b674539f} MMC has detected an error in a snap-in and will unload it.
  • When you click All Programs, the shortcut for the Exchange Management Shell may be missing from the Microsoft Exchange Server 2007 program group.

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Cause

This issue occurs because this in-place upgrade is not supported. For more information, visit the following Web site:

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Resolution

To resolve this issue, follow these steps.

Step 1: Recover the Exchange Management Shell functionality

To help you maximize the data that you can salvage from the server, you must first recover the Exchange Management Shell functionality. Windows PowerShell was removed before you performed the in-place upgrade. Therefore, the Exchange Management Shell functionality is broken.

To recover the Exchange Management Shell functionality, follow these steps:
  1. Install Windows PowerShell. To do this, run the following command while you are logged on as an administrator:
    ServerManagerCmd -i PowerShell
    Or, install the Windows PowerShell by using the Windows Server 2008 Server Manager "Add Features" functionality.
  2. Create an Exchange Management Shell shortcut. To do this, follow these steps:
    1. Right-click the desktop, click New, and then click Shortcut.
    2. In the Type the location of the item field, enter the following path:
      C:\WINDOWS\system32\windowspowershell\v1.0\powershell.exe -PSConsoleFile "C:\Program Files\Microsoft\Exchange Server\bin\exshell.psc1" -noexit -command ". 'C:\Program Files\Microsoft\Exchange Server\bin\Exchange.ps1'"
      Note Enter this path as a single line of text. This path assumes that Exchange Server 2007 is installed in the following folder:
      C:\Program Files\Microsoft\Exchange Server
      If Exchange Server 2007 is installed in a different location, replace that part of the path so that it points to the Exchange Server "bin" directory.
    3. Click Finish.
The following sections describe the procedures that you should follow for the specific roles that you may have installed on the server. If you have multiple server roles installed, you may have to follow multiple procedures.

Unified Messaging server role

You may have to back up several items from the server, depending on its configuration.

If the server was configured for customer audio prompts and was configured as the Unified Messaging prompt publishing server, copy the custom audio files to a network location. For more information about how to do this, visit the following Microsoft Web site:

Edge Transport server role

Export the Edge Transport server configuration data by running the ExportEdgeConfig.ps1 script. Then, import the output of this script into the server as soon as the server role is reinstalled on Windows Server 2003. The Edge Transport server role does not belong to a domain. Therefore, this is the only way to back up its configuration data.

For more information about Edge Transport server data backup and recovery, visit the following Microsoft Web site:For step-by-step information about how to import the Edge Transport server data into the server as soon as the server role is reinstalled, visit the following Microsoft Web site:

Hub Transport server role

The data that is stored locally on a Hub Transport server is as follows:
  • Manual changes to the EdgeTransport.exe file

    Note If you made manual changes to EdgeTransport.exe.config file, you should back up this file. For more information about the location of this file, visit the following Microsoft Web site:
  • Message queues and tracking and protocol logs

    Notes
    • Message queues can be mounted on a new server if they are recovered from a failed server.
    • You may have to have tracking and protocol logs that contain historical data for forensic analysis.
For more information about how to back up Hub Transport server data that is stored locally, visit the following Microsoft Web site:

Client Access server role

For information about how to back up data that is stored locally on the Client Access server, see the "Client Access Server Role" section in the "Migrating Exchange 2007 on Windows Server 2003 to Exchange 2007 SP1 on Windows Server 2008" topic. To do this, visit the following Microsoft Web site:

Mailbox server role

The main information that you must back up from the Mailbox server role is the Exchange store databases.

To make sure that the Exchange store databases are in a "Clean Shutdown" state before you back them up, you should run the ESEUTIL /mh command against the database files. Run this command against all Exchange store databases that you have in all storage groups on the server. Do this to determine the overall state of the server data.

For more information about how to run the ESEUTIL /mh command, visit the following Microsoft Web site:As soon as you have the output, look for the following message:
State: Clean Shutdown
If the state of the databases is "Clean Shutdown," you can back up the databases whose file name extension is .edb as-is. Copy the databases to a network location, or copy them to drives or to partitions that will not be affected by the server rebuild.

If the state of the databases is "Dirty Shutdown," the fact that the Microsoft Exchange Information Store service would not start prevents the ordinary soft-recovery process that occurs when Exchange databases are mounted. In this case, you must use the Eseutil /r command to perform a soft recovery of the databases.

If no drive letters have changed because of the operating system in-place upgrade, you should run the Eseutil /r Enn command against any storage groups that contain databases that are in a "Dirty Shutdown" state.

Note "Enn" is a prefix of the transaction log name for a specific storage group, such as E00, E01, E02, and so on.

The recovery process reads the checkpoint file and then commits any uncommitted transactions in the transaction logs to the database. If no checkpoint file exists, the replay process starts with the oldest transaction log file that is available.

For more information, visit the following Microsoft Web site:After the soft-recovery process is complete, run the ESEUTIL /mh command against the database files to determine the state of the database. Run this command against all Exchange store databases that you have on the server in all storage groups. As soon as the databases are in a "Clean Shutdown" state, you can copy them from the server as was described previously.

Important Do not try to start the Microsoft Exchange Information Store service while the server is in this state. If you start the Microsoft Exchange Information Store service and mount the databases, the database index rebuild process is initiated. (This situation occurs when the operating system version is changed.) This index is incompatible with Windows Server 2003. Therefore, when the databases are eventually restored on Windows Server 2003, they cannot start.

Step 2: Reinstall the original operating system

To do this, follow these steps:
  1. Shut down the existing Exchange Server 2007-based server that was upgraded in-place to Windows Server 2008.
  2. Reset the computer account for the existing Exchange Server 2007-based server that was upgraded in-place. To do this, follow these steps:
    1. In the Active Directory Users and Computers Microsoft Management Console (MMC) snap-in, locate the computer account for the existing Exchange Server 2007-based server that you are moving. Right-click the computer account, and then click Reset Account.
    2. Reinstall the original operating system that was running before the in-place upgrade occurred.
    3. Bring this new computer online, and then confirm that it is running the same operating system that was installed on the existing Exchange Server 2007-based server before the in-place upgrade occurred. This includes the service pack version.

      Note When you first bring the new server online, make sure that the new server has a unique computer name on the network.
    4. Rename the new server to the same name as the original server that you are replacing, and then join this computer to the domain.

      Important You must not delete the original computer account from the domain before you join the new server to the domain. Also, do not delete the original Exchange Server 2007-based server by using either the Exchange Management Console or the Exchange Management Shell.
  3. For drives that contained Exchange Server 2007 data, configure drive letters on the new server to map to or to match the configuration of the old server. Verify that the drives have sufficient space to accommodate the restored data.

Step 3: Revert the Exchange Server 2007-based server to Windows Server 2003

The following table describes the actions to take to revert the Exchange Server 2007-based server to Windows Server 2003. The actions that you take differ based on the server roles that were originally installed on the server.
Roles that were installed before the in-place upgrade to Windows Server 2008 occurredAction to take
Mailbox, Client Access, Hub Transport, or Unified MessagingRun the setup process by using the /RecoverServer switch. For more information, visit the following Microsoft Web site:

http://technet.microsoft.com/en-us/library/aa998656.aspx
Edge Transport serverInstall a new Edge Transport server role server, and then import the information that you exported from the server. For more information, visit the following Microsoft Web site:

http://technet.microsoft.com/en-us/library/bb332339.aspx
Mailbox on a clustered serverUse RecoverCMS to recover a clustered mailbox server. For more information, visit the following Microsoft Web site:

http://technet.microsoft.com/en-us/library/bb124095.aspx

Step 4: Prepare to migrate Exchange Server 2007 to Windows Server 2008

To do this, restore the role-specific information that you manually backed up.

Note If Event ID 9519 occurs when you restore the Exchange store databases, follow the steps in the "MSExchangeIS 9519 (0x3f3): Unchecked 'This database can be overwritten by a restore' Check Box After Restore" topic. To do this, visit the following Microsoft Web site:After you do this, the server functionality is returned to the state in which it was before the in-place upgrade occurred.

Now you are ready to migrate Exchange Server 2007 to Windows Server 2008. To do this, follow the steps that are described in the "Migrating Exchange 2007 on Windows Server 2003 to Exchange 2007 SP1 on Windows Server 2008" topic. To view this topic, visit the following Microsoft Web site:

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Keywords: KB951402, kbprb, kbexpertiseinter, kbtshoot

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Article Info
Article ID : 951402
Revision : 1
Created on : 4/18/2008
Published on : 4/18/2008
Exists online : False
Views : 660