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The IMAP4 or POP3 worker process may stop responding on an Exchange 2007 CAS role when you use an IMAP4 client or a POP3 client to connect the Exchange 2007 CAS role to your mailbox


View products that this article applies to.

Symptoms

When you use an IMAP4 client or a POP3 client to connect the Microsoft Exchange Server 2007 Client Access server (CAS) role to your mailbox, the IMAP4 or POP3 worker process may stop responding on the CAS role. This is true if your mailbox is hosted on a Microsoft Exchange Server 2003 back-end server. This problem prevents IMAP4 and POP3 clients from retrieving messages. When this problem occurs, the following events are logged in the Application event logs:


Event Type: Error
Event Source: .NET Runtime 2.0 Error Reporting
Event Category: None
Event ID: 5000
Description: Event Type clr20r3, P1 microsoft.exchange.imap4.exe, P2 <version>, P3 <address>, P4 microsoft.exchange.data.storage, P5 8.0.0.0, P6 47427a4e, P7 1f1f, P8 42, P9 5zyl3ckgvu1whmz2zgn4mmb2me1gjsgx, P10 NIL.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


Event Type: Information
Event Source: MSExchange IMAP4 service
Event Category: ProcessManager
Event ID: 1020
Description: Worker process with process ID <ID> has exited.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Note The POP3 service logs similar events on the Exchange 2007 CAS role.

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Cause

This issue occurs when the CalendarItemRetrievalOption option on the Exchange 2007 CAS role is set to InternetUrl or intranetUrl. In this case, the Exchange 2007 CAS role tries to find the Outlook Web Access server. However, Exchange 2003 is not recognized in this situation. Then, the exception occurs, and the CAS role does not correctly handle the exception.

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Resolution

To resolve this problem, download Update Rollup 4 for Exchange 2007 Service Pack 1. For more information about Update Rollup 4 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic: For more information about how to obtain the latest Exchange service pack or update rollup, see the following Exchange Help topic:

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Workaround

To work around this issue, change the CalendarItemRetrievalOption option to other valid values. To do this, run one of the following commands:

For IMAP 4 service
Set-ImapSettings -CalendarItemRetrievalOption iCalendar
Set-ImapSettings -CalendarItemRetrievalOption Custom -OwaServerUrl <http url of OWA server>

For POP3 service
Set-POPSettings -CalendarItemRetrievalOption iCalendar
Set-POPSettings -CalendarItemRetrievalOption Custom -OwaServerUrl <http url of OWA server>

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More information

For more information about the Set-IMAPSettings command, visit the following Web site:For more information about the Set-POPSettings command, visit the following Web site:

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB950235, kbqfe, kbhotfixserver, kbexpertiseadvanced, kbfix, kbhotfixrollup

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Article Info
Article ID : 950235
Revision : 2
Created on : 10/7/2008
Published on : 10/7/2008
Exists online : False
Views : 405