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A user may be unable to synchronize with an Exchange Server mailbox from a mobile device when a Client Access server has been upgraded to Exchange Server 2007 Service Pack 1


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You upgrade to Microsoft Exchange Server 2007 Service Pack 1 (SP1) on the Client Access server
  • A user who has a mobile device may try to connect to a mailbox on an Exchange Server 2003-based server.
In this scenario, the user may be unable to synchronize with the mailbox any more. If verbose logging is enabled on the mobile device, the "HTTP 503" error code is logged.

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Cause

This problem occurs because the SAMAccountName attribute of the mobile device user matches the Simple Mail Transfer Protocol (SMTP) address of another user on a different mailbox server . The server that is running Exchange Server 2007 SP1 assumes that its SMTP address belongs to another user on another mailbox server. Therefore, the �HTTP 302� error code is returned. The Exchange ActiveSync handler assumes that a mailbox has been recently migrated from Exchange Server 2003 to Exchange Server 2007. Therefore, the handler blocks synchronization until replication is complete. In this scenario, the user can never synchronize with the mailbox.

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Resolution

Update information

Download and install Update Rollup 2 for Exchange Server 2007 SP1. For more information about Update Rollup 2 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic: For more information about how to obtain the latest Exchange service pack or update rollup, see the following Exchange Help topic:

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Workaround

To work around this problem, change the primary SMTP address on the E-mail Addresses tab of the user account property so that it does not match the SAMAccountName attribute of another user.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

To enable verbose logging on the mobile device, follow these steps:
  1. Open ActiveSync from the mobile device, click Menu, and then click Configure Server.
  2. In the Edit Server Settings window, click Next.
  3. Click Advanced.
  4. In the Event logging field, click Verbose, click Next, and then click Finish.

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Keywords: KB948831, kbhotfixrollup, kbqfe, kbfix, kbbug

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Article Info
Article ID : 948831
Revision : 2
Created on : 5/8/2008
Published on : 5/8/2008
Exists online : False
Views : 407