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After you synchronize directory information from Exchange Server 2007 and from Lotus Domino 7.0.2 , error messages may be logged


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Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows XP and Windows Vista

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Symptoms

After you synchronize directory information from Microsoft Exchange Server 2007 and from Lotus Domino 7.0.2 directory, the following error messages may be logged in the Application log:
Event Type: Error
Event Source: ExchangeDominoConnector
Event Category: Exchange Domino Connector
Event ID: 8225
Description: Process dxa terminated unexpectedly
Event Type: Error
Event Source: ExchangeDominoConnector
Event Category: Domino Directory Synchronization
Event ID: 41205
Description: Cannot find Notes INI file. Ensure NOTES.INI in ExchConn subdirectory or on PATH
Event Type: Error
Event Source: ExchangeDominoConnector
Event Category: Domino Directory Synchronization
Event ID: 64013
Description: Failed to initialize the NOTES subsystem
If you resolve the path issue of the Notes.ini file, and then you resynchronize the directory information, the following errors may be logged in the Application log:
Event Type: Error
Event Source: ExchangeDominoConnector
Event Category: Domino Directory Synchronization
Event ID: 41116
Description: Error opening Notes document with id = 353e
Event Type: Error
Event Source: ExchangeDominoConnector
Event Category: Domino Directory Synchronization
Event ID: 41127
Description: Notes Package ID: Notes Storage Facility (NSF). Extended Reason String: You are not authorized to perform that operation

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Cause

This problem occurs if multiple Notes.ini files exist or if insufficient permissions are set for the Notes.nsf file.

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Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, follow these steps:
  1. From the Lotus Domino server, make sure that you can see the Lotus Notes users.
  2. Use the following transport shell command to set the Logging level to high.
    Set-TransporterEventLogLevel -Identity DominoDirectoryConnector\DirSync -LoggingLevel High
  3. Use the following transport shell command to manually force the synchronization.
    Start-DominoDirectoryConnector -UpdateToAD �UpdateToDomino
  4. After the command to manually force the synchronization from the transport shell is complete, verify that the events in the Application log do not show any errors for the transport shell. To do this, check the Application log to determine whether any new error messages have been logged.
  5. Uninstall and then reinstall the Lotus Notes 7.0.2 client. To do this, follow these steps:
    1. In Control Panel, uninstall the Lotus client from Add Or Remove Programs.
    2. Delete the Lotus directory.

      Note On a 64-bit computer, the default Lotus directory is as follows:
      drive:\Program Files (x86)\Lotus\Notes\Data
    3. Delete the following Lotus registry subkeys:
      HKEY_LOCAL_MACHINE\Software\Lotus
      HKEY_Current_User\Software\Lotus
    4. Delete the Nnotes.dll file from the following directory:
      drive:\Windows\System32
    5. Restart the computer.
    6. Use the "Only Me" option to install the Lotus client. When you are prompted to configure a profile to complete Setup, make sure that the "Office Mode" option is selected.
    Note Make sure that the Lotus client is installed by using the "Only Me" option and not by using the "Multiple User" option. If the Lotus client is installed by using the "Multiple User" option, permission issues may occur.
  6. Verify how many Notes.ini files are present. There should be only one Notes.ini file that is using the DominoDirectory connector.

    Note If many user profiles for different domains are logged on to the server, multiple Notes.ini files may be present.
  7. At the command prompt, run the following command to identify the path of the correct Notes.ini file.
    Get-DominoDirectoryConnector
    The Notes.ini file is typically located in the following directory:
    drive:\Program Files (x86)\Lotus\Notes
    If you receive a "- 8225" error when you run this command, the path of the Notes.ini file cannot be located. In this case, make sure that the path of the Notes.ini file that is listed under Environment Variables is correct. To do this, right-click My Computer, click Properties, click the Advanced tab, and then click Environment Variables. If the Notes.ini path is incorrect, use the following command to set the correct path:
    Set-DominoDirectoryConnector -NotesIniFile File_Path\notes.ini
    Note If there are multiple Notes.ini files, rename the other Notes.ini files. Make sure that you keep the file in the drive:\Program Files (x86)\Lotus\Notes directory.
  8. Note the account that is used to complete the installation. This account is used only to install the Lotus client.

    Note For more information, double-click the Lotus icon, and then enter this account.

    Make sure that this account has sufficient permissions for the Notes.nsf file. Also make sure that you used this account to log on to the domain.

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More information

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: KB948213, kbexpertiseinter, kbprb, kbtshoot

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Article Info
Article ID : 948213
Revision : 2
Created on : 2/20/2008
Published on : 2/20/2008
Exists online : False
Views : 276