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Double-coded characters in the address stamp that Exchange Server 2007 stamps on an e-mail message may appear incorrectly


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Symptoms

Consider the following scenario:
  • In a Microsoft Exchange Server 2007 environment, the First Name section or the Last Name section of a user object includes one of the following double-coded characters:
  • The e-mail message address policy uses FirstName (givenName) or LastName (surName) fields.
In this scenario, the address stamp that Exchange 2007 stamps on an e-mail message may resemble the following.
First Name:�mer
Last Name:�g�n�
Policy %g.%s@contoso.com
Exchange generate e-mail address: Oemer.Oeguenc@contoso.com 
The double-coded characters in the address stamp appear incorrectly. Exchange 2007 substitutes the "ue" character for the "�" character and the "oe" character for the "�" character.

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Cause

This problem may occur because you used English language regional settings when you installed the Microsoft .NET Framework 2.0. If you use double-coded characters, you have to configure the correct regional settings before you run the .NET Framework Setup.

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Resolution

To resolve this problem, use one of the following methods.

Method 1: Change your current e-mail address policy for correct character replacement

To resolve this problem, change your current e-mail address policy for correct character replacement. To do this, open Exchange Management Shell and update your current e-mail address policy. Then, apply the e-mail address policy to your accounts.

For example, you may have the %g.%s@contoso.com e-mail address policy, and you may have the �,� character problem. To resolve this problem, you must change the e-mail address policy for correct character replacement to the following:
%r�u%r�o%g.%r�u%r�o%s@contoso.com
For more information about e-mail address policies, click the following article number to view the article in the Microsoft Knowledge Base:
822447 How to modify an SMTP e-mail address by using recipient policies

Method 2: Change regional settings and reinstall the .NET Framework

Note This method applies if the Exchange mailbox server is running on Windows Server 2003.

To resolve this problem, follow these steps:
  1. Stop all Exchange-related services on the Exchange 2007-based mailbox server.
  2. Change the startup mode for the Cluster service and for Exchange-related services from Automatic to Manual.
  3. Uninstall any .NET Framework 2.0 updates that are present on the server.
  4. Uninstall the .NET Framework 2.0 from the server.
  5. Change the regional settings from English to Turkish. To do this, follow these steps:
    1. Open Control Panel.
    2. Double-click Regional and Language Options, and then set the Standards and formats section to Turkish.
    3. Click the Advanced tab, and then set Language for non-Unicode programs to Turkish.
    Note Make sure that the Default user account settings check box is selected, click Apply, and then click OK. Turkish is a sample language for double-coded character supports. You can also follow these steps for other languages that support double-coded characters.
  6. Restart the server.
  7. Reinstall the .NET Framework 2.0 on the server.
  8. Reinstall the .NET Framework 2.0 updates on the server.
  9. Change the startup mode for the Cluster service and for Exchange-related services from Manual to Automatic.
  10. Restart the Cluster service and the Exchange-related services on the server.
Note If you have to apply these same steps on a cluster continuous replication (CCR) cluster or on a single-copy cluster, apply the steps on the passive node first, and then follow the same steps on the active node.

Method 3: Change regional settings from English to Turkish

Note This method applies if exchange server is running on Windows Server 2008.

To resolve this problem, change the regional settings from English to Turkish. To do this, follow these steps:
  1. Open Control Panel.
  2. Double-click Regional and Language Options, and then click Turkish (Turkey) in the Current format box.
  3. On the Administrative tab, click Change system locale.
  4. Click Turkish (Turkey) in the Current System Locale box, and then click OK.
  5. On the Administrative tab, click Copy to reserved accounts.
  6. Click to select the following check boxes, and then click OK:
    • Default user account (new users)
    • System accounts (local system, local service, and network service)
  7. Restart the server.

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Keywords: KB948212, kbprb, kbexpertiseinter, kbtshoot

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Article Info
Article ID : 948212
Revision : 3
Created on : 8/7/2009
Published on : 8/7/2009
Exists online : False
Views : 337