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The Information Store service intermittently stops responding after you apply Exchange Server 2007 SP1 on an Exchange Server 2007-based server


View products that this article applies to.

Symptoms

After you apply Microsoft Exchange Server 2007 Service Pack 1 (SP1) on an Exchange Server 2007-based server, the Information Store service intermittently stops responding. Additionally, the following errors may be logged in the Application log:

Event Type: Error
Event Source: MSExchange Common
Event Category: General
Event ID: 4999
Description: Watson report about to be sent to dw20.exe for process id: <process ID of store.exe>, with parameters: E12N, c-rtl-AMD64, 08.01.0240.006, store.exe, EXOLEDB.DLL, d0cd1, c0000005, a9aa, 08.01.0240.005

Event Type: Error
Event Source: Application Error
Event Category: (100)
Event ID: 1000
Description: Faulting application store.exe, version 8.1.240.5, faulting module exoledb.dll, version 8.1.240.5, fault address <address>.

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Cause

This problem occurs because of an issue with the get_UserSid method. A store event sink is registered and calls the get_UserSid method.

For more information, visit the following Microsoft MSDN Web site:

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Resolution

To resolve this problem, install Update Rollup 1 for Exchange Server 2007 SP1 on the server. For more information about Update Rollup 1 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic: For more information about how to install the latest Exchange service pack or update rollup, see the following Exchange Help topic:

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Workaround

To work around this problem, remove any store event sinks that call the get_UserSid method.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Currently, the only reported instances of this problem are related to a third-party product that is called RealTime Service. The vendor company, Add-On Products, has released a RealTime Service update that removes remove any calls to the get_UserSid method. For more information about this update, visit the following Add-On Products Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages


The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: KB945938, kbhotfixrollup, kbqfe, kbfix, kbexpertiseinter

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Article Info
Article ID : 945938
Revision : 7
Created on : 1/21/2008
Published on : 1/21/2008
Exists online : False
Views : 474