Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The "eseutil /k" command takes a long time to verify the checksum of transaction logs in Exchange Server 2007 Service Pack 1


View products that this article applies to.

Symptoms

On a computer that is running Microsoft Exchange Server 2007 Service Pack 1 (SP1), you use the eseutil /k command to verify the checksums of some transaction logs. However, the time that is required to verify the checksums increases as the number of transaction logs increases. For example, it may take 10 minutes to verify the checksums of 10,000 transaction logs. However, it may take 30 minutes to verify the checksums for 20,000 logs. The time to verify the checksums increases exponentially.

↑ Back to the top


Cause

This issue occurs because the transaction logs are verified one at a time, and the original arithmetic for searching the next file is inefficient.

↑ Back to the top


Resolution

To resolve this problem, install Update Rollup 9 for Exchange 2007 Service Pack 1. For more information about Update Rollup 9 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic: For more information about how to install the latest Exchange service pack or update rollup, see the following Exchange Help topic:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB945877, kbexpertiseadvanced, kbqfe, kbfix, kbhotfixrollup

↑ Back to the top

Article Info
Article ID : 945877
Revision : 2
Created on : 7/17/2009
Published on : 7/17/2009
Exists online : False
Views : 311