Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Cannot Migrate Lotus Notes User to Exchange Server 2007 Because UserPrincipalName Is Not Set


View products that this article applies to.

Rapid publishing

Source: Microsoft Support

↑ Back to the top


Action

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

↑ Back to the top


Result



Try to migrate users from Lotus Notes to Exchange Server 2007 by using Lotus Transporter Suite.

↑ Back to the top


Cause

Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:08

TestUser
Failed

Error:
Error: User TestUser/OU/O could not be migrated to ExchangeServer.

Warning:
Error: User TestUser can not be enabled.

Exchange Management Shell command attempted:
'CN=TestUser/OU=OU/O=O' | move-dominouser -Quiet -DominoDirectoryServer $null -DomainController 'DC' -TargetOU 'OU=Migrated to Lotus Notes,DC=Test' -InitialPassword 'System.Security.SecureString' -TargetMailboxDatabase 'ExchangeServer\SG\DB'

Elapsed Time: 00:00:08

↑ Back to the top


Resolution

The user's UserPrincipalName is not set.

↑ Back to the top


Disclaimer



To set UserPrincipalName with a user's email address properly:

1. Click Start -> Run... -> Type "adsiedit.msc" and Click OK.
2. Right Click the user and Click Properties.
3. DoubleClick the UserPrincipalName.
4. Input user's email address and Click OK.

↑ Back to the top


Keywords: KB945645, kbrapidpub, kbnomt

↑ Back to the top

Article Info
Article ID : 945645
Revision : 1
Created on : 11/28/2007
Published on : 11/28/2007
Exists online : False
Views : 239