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A time-out may occur in Exchange Server 2007 when the SA resource is trying to come online


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Symptoms

In Microsoft Exchange Server 2007, you may experience a time-out problem when you use the System Attendant (SA) resource on a Single Copy Cluster (SCC) or on a Continuous Copy Cluster (CCR). The time-out occurs when the SA resource is trying to come online. This problem may occur during Setup, after a restart, after a failover, or after you move a group by using the move-clusteredMailboxServer cmdlet.

Additionally, the following events may be logged in the System log:

Event Type: Error
Event Source: ClusSvc
Event Category: (3)
Event ID: 1069
Description: Cluster resource 'Exchange System Attendant Instance (E12VIRTMBX1)' in Resource Group 'E12VIRTMBX1' failed.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7034
Description: The Microsoft Exchange System Attendant service terminated unexpectedly. It has done this 10 time(s).

Event Type: Information
Event Source: Service Control Manager
Event Category: None
Event ID: 7035
Description: The Microsoft Exchange System Attendant service was successfully sent a start control.

Event Type: Information
Event Source: Service Control Manager
Event Category: None Event ID: 7036
Description: The Microsoft Exchange System Attendant service entered the running state.

Event Type: Error
Event Source: ClusSvc
Event Category: (3)
Event ID: 1069
Description: Cluster resource 'Exchange System Attendant Instance (E12VIRTMBX1)' in Resource Group 'E12VIRTMBX1' failed.

Event Type: Information
Event Source: ClusSvc
Event Category: (3)
Event ID: 1205
Description: The Cluster Service failed to bring the Resource Group "E12VIRTMBX1" completely online or offline.

The following events may be logged in the Application log:

Event Type: Error
Event Source: MSExchange Cluster
Event Category: (6)
Event ID: 1019
Description: Clustered Mailbox Server: ? Physical Server: Failed to bring the resource Exchange System Attendant Instance (CMS Name) online due to a timeout.

Event Type: Error
Event Source: MSExchange Cluster
Event Category: (6)
Event ID: 1003
Description: Clustered Mailbox Server: ? Physical Server: Failed to bring the resource Exchange System Attendant Instance (CMS Name) online.

Event Type: Warning
Event Source: MSExchange Cluster
Event Category: (6)
Event ID: 1030
Description: Clustered Mailbox Server: E12VIRTMBX1 Physical Server: UDGIA181 Exchange System Attendant Instance (CMS Name): Terminate process called for MSExchangeSA (ProcessId 4704).

Event Type: Error
Event Source: MSExchange Cluster
Event Category: (6)
Event ID: 1011
Description: Exchange System Attendant Instance (CMS Name): The RPC call to the service to bring the cluster resource online failed.

Event Type: Error
Event Source: MSExchange Cluster
Event Category: (6)
Event ID: 1003
Description: Clustered Mailbox Server: Physical Server: Failed to bring the resource Exchange System Attendant Instance (CMS Name) online.

Event Type: Warning
Event Source: MSExchange Cluster
Event Category: (6)
Event ID: 1030
Description: Clustered Mailbox Server: Physical Server: Exchange System Attendant Instance (CMS Name): Terminate process called for MSExchangeSA (ProcessId 4704).

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Cause

Although the System Attendant service starts, the service times out while it waits for the SA resource.

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Resolution

To resolve this problem, use a different time-out value.

The SA resource fails because it is not completing initialization before the 40-second time-out. The cluster pending time-out value for the SA resource is 180 seconds. However, the Exres.dll file uses an internal time-out value of 40 seconds. The Exres.dll file is not honoring the default setting of 180 seconds for the SA resource. However, if you set any other time-out value for the SA resource, the setting is observed. You can set the time-out value by using Cluster Administrator (CluAdmin.exe) or by using a command prompt.

To use Cluster Administrator to set a time-out value

Open the properties of the SA resource, click the Advanced tab, and then change the pending time-out value to 150 seconds.

To use the command prompt to set a time-out value

Opan a command prompt, type the following command, and then press ENTER:
cluster res �Exchange System Attendant Instance (CMS Name)� /prop PendingTimeout=150000

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More information

If an Exchange 2007 cluster is experiencing the problems that are described in this article, there may be underlying Active Directory directory service issues.

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Keywords: KB945078, kbexpertiseinter, kbprb, kbtshoot

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Article Info
Article ID : 945078
Revision : 1
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 269