Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The public folder store may take several minutes to mount on an Exchange 2007 server


View products that this article applies to.

Symptoms

You have a Microsoft Exchange Server 2007 environment that has many public folder stores spread out across slow wide area network (WAN) links. In this situation, the public folder store on an Exchange 2007 server may take several minutes to mount.

↑ Back to the top


Cause

This problem occurs because Exchange 2007 tries to contact every server that holds public folder stores when a public folder store is mounted. This behavior generates a remote procedure call (RPC) to the servers across the WAN links. The RPC can take several seconds for each server. Therefore, a long delay occurs before the public folder store mounts.

↑ Back to the top


Resolution

To resolve this problem, download and install Update Rollup 2 for Exchange 2007 Service Pack 1. For more information about Update Rollup 2 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic: For more information about how to install the latest Exchange service pack or update rollup, see the following Exchange Help topic:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB940462, kbtshoot, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 940462
Revision : 4
Created on : 9/10/2008
Published on : 9/10/2008
Exists online : False
Views : 474