Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Exchange 2007 users receive a non-delivery report (NDR) message when they try to send an e-mail message that is addressed to a third-party connector address


View products that this article applies to.

Symptoms

Consider the following scenario.
  • You are using a third-party connector on a computer that is running Microsoft Exchange Server 2007. Or, a third-party connector is installed on an Exchange 2000 or Exchange 2003 server that is running in an Exchange organization that includes Exchange 2007 servers.
  • From a mailbox located on the Exchange 2007 server, you try to send an e-mail message to an address type that is supported by the third-party connector.

    Note An example of a third-party connector is a fax connector that supports an address type of FAX.
In this scenario, you receive a non-delivery report (NDR) message that resembles the following message:
Your message did not reach some or all of the intended recipients.
Subject:<subject>
Sent: <date,time>
The following recipient(s) could not be reached: <name>(FAX)<date,time>
None of your e-mail accounts could send to this recipient.

↑ Back to the top


Cause

In this scenario, when the Microsoft Exchange Information Store service is started, Exchange 2007 loads the list of address types. Then, Exchange sorts the address types into an array. However, the sorting algorithm uses the wrong index.

This behavior causes an array corruption. When Outlook sends a message, Outlook asks for the list of supported address types. Exchange returns this corrupted array. If Outlook has to send mail to an address type that is not in the list, Outlook concludes that Exchange cannot handle the address type on the message. Therefore, Outlook never submits the message to Exchange to be processed.

When this behavior occurs, the e-mail client that was used to send the e-mail message in the "Symptoms" section receives an NDR message.

↑ Back to the top


Resolution

To resolve this problem, install Update Rollup 4 for Exchange Server 2007. For more information about Update Rollup 4 for Exchange Server 2007, see the following Exchange Help topic: For more information about how to install the latest Exchange service pack or update rollup, see the following Exchange Help topic:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
817903 New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB937861, kbexpertiseinter, kbqfe

↑ Back to the top

Article Info
Article ID : 937861
Revision : 6
Created on : 10/19/2007
Published on : 10/19/2007
Exists online : False
Views : 382