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FIX: Error message when you run an application that starts new processes from an impersonated context on a computer that has Windows Internet Explorer 7 installed: "Access is denied"


View products that this article applies to.

Symptoms

When you run an application on a computer that has Windows Internet Explorer 7 installed, you receive an error message that resembles the following:
Access is denied
This problem occurs when you develop an application that starts new processes from an impersonated context.

Note This problem does not occur on a computer that has Microsoft Internet Explorer 6 installed.

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Cause

This behavior occurs because the application calls the ShellExecuteEx function by using a thread that is running under an impersonated context. When the application calls the ShellExecuteEx function, the thread tries to access the
HKEY_CURRENT_USER
registry key. By design, because the thread does not have permission to access the
HKEY_CURRENT_USER
registry key, the application cannot call the function successfully.

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Resolution

Windows Vista

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To enable the hotfix, follow these steps:
  1. Click Start, type regedit in the Start Search box, and then press ENTER.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type the following key name, and then press ENTER:
    FEATURE_INITIALIZE_URLACTION_SHELLEXECUTE_TO_ALLOW_KB936610
  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type Appname.exe , and then press ENTER

    Note Appname.exe represents the process name of the application that you develop.
  7. On the Edit menu, click Modify.
  8. Type 1, and then click OK.
  9. Exit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit version
File nameFile versionFile sizeDateTimePlatform
Urlmon.dll7.0.6000.205931,155,07208-May-200702:50x86

Microsoft Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2003 Service Pack 2 (SP2) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To enable the hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then press ENTER.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type the following key name, and then press ENTER:
    FEATURE_INITIALIZE_URLACTION_SHELLEXECUTE_TO_ALLOW_KB936610
  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type Appname.exe , and then press ENTER.

    Note Appname.exe represents the process name of the application that you develop.
  7. On the Edit menu, click Modify.
  8. Type 1, and then click OK.
  9. Exit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 SP2, 32-bit version
File nameFile versionFile sizeDateTimePlatform
Urlmon.dll7.0.6000.205931,155,07209-May-200723:04x86

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Status

This behavior is by design. This problem was first corrected in Windows Vista Service Pack 1.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB936610, kbhotfixserver, kbqfe, kbfix, kbexpertiseadvanced, kbvistasp1fix, kbautohotfix

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Article Info
Article ID : 936610
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 472