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The Unified Messaging service may not submit voice messages to the Hub Transport server in Exchange 2007


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Symptoms

The Microsoft Exchange Server 2007 Unified Messaging service may not submit voice messages to the Hub Transport server. Additionally, one of the following events may be logged in the System event log:

Event Type: Error
Event Source: MSExchange Unified Messaging
Event Category: UMService
Event ID: 1082
Description:
The Unified Messaging server was unable to submit messages to a Hub Transport server because there is no Hub Transport server available to process the request with UM header file "C:\Program Files\Microsoft\Exchange Server\UnifiedMessaging\voicemail\a7bf917e-0d80-43c5-9b23-8cc4068e3ef9.txt". Make sure that there is a Hub Transport server located in the same Active Directory site as the UM server. In addition, make sure that the Microsoft Exchange Transport service is started on the Hub Transport server.

Event Type: Warning
Event Source: MSExchangeTransport
Event Category: SmtpReceive
Event ID: 1037
Description:
Inbound direct trust certificate with thumbprint
3EAC148B742F19E23B369950E51A0ABC5D456EC5 has expired. Run New-ExchangeCertificate to generate a new direct trust certificate.

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Cause

This issue may occur if any of the following conditions is true:
  • The fully qualified domain name (FQDN) of the default receive connector on the Hub Transport server differs from the internal FQDN of the Hub Transport server.
  • The default receive connector was deleted.
  • A new certificate is installed on the Hub Transport server. However, the Hub Transport server is not configured to use the new certificate. This cause is specific to the event ID 1037 message that is mentioned in the "Symptoms" section.
  • The SmtpSvc/UM_NetBiosName service principal name (SPN) records and the SmtpSvc/UM_FQDN SPN records are missing on the unified messaging server. This is an unlikely cause because these SPN records are automatically reregistered when the Unified Messaging service restarts.

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Resolution

To resolve this issue, follow these steps.

Note After each step in the following procedure, test to determine whether the problem is resolved.
  1. Verify that the FQDN of the receive connector matches the FQDN of the Hub Transport server.
    1. Start the Exchange Management Console.
    2. Expand Server Configuration, and then click Hub Transport.
    3. Under Receive Connectors, right-click the default Hub Transport server receive connector, and then click Properties.
    4. On the General tab, verify that the FQDN of the receive connector matches the FQDN of the Hub Transport server.
    Note If you change the FQDN of the default receive connector for purposes such using the same connector for Internet mail flow, create a new connector for Internet mail flow. Additionally, leave the FQDN of the default receive connector unchanged.
  2. Create a new receive connector that has the same settings as the default connector. To do this, start the Exchange Management Shell, and then run the following cmdlet:
    new-receiveconnector -Name "Default YOUR_HUB_SERVER_NETBIOS_NAME_HERE" 
    -MaxRecipientsPerMessage 5000 -Fqdn YOUR_HUB_SERVER_FQDN_NAME_HERE -Bindings 
    '0.0.0.0:25' -RemoteIPRanges '0.0.0.0-255.255.255.255' 
    -MaxInboundConnectionPerSource Unlimited -MaxInboundConnectionPercentagePerSource 
    100 -SizeEnabled EnabledWithoutValue
    Note This cmdlet is documented in the "C:\ExchangeSetupLogs\Install-BridgeheadRole-XXXXX-XXXXXX.ps1" file.

    Alternatively, manually create the receive connector in Exchange System Manager. Then, manually configure the settings to match the default settings.
  3. If event ID 1037 is logged in the System event log, follow these steps to configure the certificate to use SMTP:
    1. Start the Exchange Management Shell.
    2. Type the following cmdlet, and then press ENTER:
      Enable-ExchangeCertificate 3EAC148B742F19E23B369950E51A0ABC5D456EC5 - Services SMTP
    3. Restart the Hub Transport service.
    4. Restart the following services:
      • Microsoft Exchange Unified Messaging service
      • Microsoft Exchange Transport service
  4. In rare cases, the SmtpSvc/UM_NetBiosName SPN records and the SmtpSvc/UM_FQDN SPN records may be missing from the unified messaging server. Restart the Unified Messaging service to reregister these SPN records. Then, check the computer account of the unified messaging server to verify that the SPN records exist.

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Keywords: KB935629, kbexpertiseadvanced, kbprb, kbtshoot

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Article Info
Article ID : 935629
Revision : 1
Created on : 5/11/2007
Published on : 5/11/2007
Exists online : False
Views : 266