Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

DBCS characters are converted into question marks in a forwarded e-mail message in Exchange 2007


View products that this article applies to.

Symptoms

Consider the following scenario. A mailbox that is located on a Microsoft Exchange Server 2007 server has a server-side rule that forwards e-mail messages to target recipients. The original e-mail message is included in the body of the forwarded message. In this scenario, the recipients experience the following symptoms:
  • If the original e-mail message contains double-byte character set (DBCS) characters in the subject line, the DBCS characters are converted into question marks in the forwarded e-mail message. This is also true if the original message contains DBCS characters in the display name of the recipient.
  • If the sender of the original e-mail message has a display name that contains DBCS characters, the sender's display name in the forwarded e-mail message is changed to the following legacyExchangeDN attribute:

    /o=<org>/ou=<AG>/cn=Recipients/cn=<xxx>

↑ Back to the top


Cause

This problem occurs because Exchange 2007 uses English as the code page when Exchange 2007 processes the server-side rule that forwards e-mail messages to target recipients. Exchange does not use the code page of an e-mail message to process the rule. The header information for the original e-mail message is incorrect if DBCS characters are included.

↑ Back to the top


Resolution

To resolve this problem, install Update Rollup 3 for Exchange Server 2007. For more information about Update Rollup 3 for Exchange Server 2007, see the following Exchange Help topic: For more information about how to install the latest Exchange service pack or update rollup, see the following Exchange Help topic:

↑ Back to the top


Workaround

To work around this problem, use the Forward it to people or distribution list as an attachment rule so that the original message will be an attachment of the forwarded message.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the terminology that Microsoft uses when software is updated, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For more information about the naming schema for Exchange Server software update packages, click the following article number to view the article in the Microsoft Knowledge Base:
817903� New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB934887, kbqfe, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 934887
Revision : 6
Created on : 8/31/2007
Published on : 8/31/2007
Exists online : False
Views : 360