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The default SMTP virtual server does not start, and event ID 429 is logged in Exchange 2000 Server


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Symptoms

When you try to start the default SMTP virtual server on a computer that is running Microsoft Exchange 2000 Server, you experience the following symptoms:
  • The default SMTP virtual server does not start.
  • The following event is logged in the System log:

    Event Type: Error
    Event Source: smtpsvc
    Event Category: None
    Event ID: 429
    Date: date
    Time: time
    User: N/A
    Computer: ServerName
    Description: Virtual Server 1: The specified mail queue directory is not valid. Cannot start the SMTP Service.

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Cause

This problem occurs if a problem exists with one or more of the following subfolders in the "Exchsrv\Mailroot\vsi1" folder:
  • Badmail
  • Pickup
  • Queue
This problem may occur if one or more of these folders are missing, or if the Exchange Server virtual server does not point to the correct folder. In this scenario, the Microsoft Exchange Routing Engine service cannot save messages to a particular folder or folders.

Note You may also experience this problem if permissions are incorrectly assigned on one or more of these folders.

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Resolution

To troubleshoot this issue, follow these steps:

Step 1: Verify that the "vsi 1" subfolders exist

Make sure that all the subfolders under the "vsi 1" folder are present. To do this, follow these steps:
  1. Start Windows Explorer, and then locate the "vsi 1" folder. By default, this folder has the following path:
    %ProgramFiles%\Exchsrvr\Mailroot\vsi 1
  2. Create all the following folders if they do not already appear under vsi 1:
    • Badmail
    • Pickup
    • Queue
  3. When you create these folders, verify that the Everyone group appears in the Permissions list.

    Additionally, verify that this group is assigned Full Control permissions to each folder. By default, this permission is inherited from the parent folder.

Step 2: Verify the paths of the "vsi 1" subfolders

Make sure that Exchange 2000 Server is configured to point to the correct location for the "vsi 1" subfolders. To do this, follow these steps.

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.
  1. Start the Active Directory Service Interfaces (ADSI) Edit tool. To do this, click Start, click Run, type adsiedit.msc, and then click OK.

    Note The ADSI Edit tool is included with the Windows Support Tools. To install the Windows Support Tools, double-click Setup.exe in the Support\Tools folder on the Microsoft Windows 2000 Server CD.
  2. Locate the default virtual server container (CN=1) in the configuration container. To do this, follow these steps:
    1. Expand Configuration Container [DomainControllerName.example.com], expand CN=Configuration,DC=example,DC=com, and then expand CN=Services.
    2. Expand CN=Microsoft Exchange, expand CN=OrganizationGroupName, and then expand CN=Administrative Groups.
    3. Expand CN=AdministrativeGroupName, expand CN=Servers, and then expand CN=ExchangeServerName.
    4. Expand CN=Protocols, and then expand CN=SMTP.
  3. Right-click CN=1, and then click Properties.
  4. Verify the paths of the following three attributes:
    • msExchSmtpBadMailDirectory
    • msExchSmtpPickupDirectory
    • msExchSmtpQueueDirectory
    To do this, follow these steps:
    1. In the Select a property to view list, click msExchSmtpBadMailDirectory.
    2. Verify the path that appears in the Value(s) box. If the path points to an incorrect location for the Badmail folder, type the correct path in the Edit Attribute box, and then click Set.
    3. Follow steps 4a and 4b for the msExchSmtpPickupDirectory attribute and the msExchSmtpQueueDirectory attribute. Modify the paths as appropriate for the corresponding folder.
    4. When you are finished verifying the paths, click OK.
  5. Exit the ADSI Edit tool.

Step 3: Restart the SMTP service and the Microsoft Exchange Routing Engine service

Restart the following two services:
  • Simple Mail Transport Protocol (SMTP)
  • Microsoft Exchange Routing Engine
To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. Type the following command, and then press ENTER:
    net stop smtpsvc && net start smtpsvc
  3. Type the following command, and then press ENTER:
    net stop resvc && net start resvc

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Keywords: KB933781, kbprb, kbtshoot, kbeventlog

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Article Info
Article ID : 933781
Revision : 1
Created on : 3/26/2007
Published on : 3/26/2007
Exists online : False
Views : 280