Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A POP3 mail client may receive an error code, and event ID 1009 is logged on an Exchange 2007 mail server


View products that this article applies to.

Symptoms

Consider the following scenario. A Microsoft Exchange Server 2007 mail server works as a proxy for a POP3 mail client. When the Exchange 2007 mail server tries to access a back-end Microsoft Exchange Server 2003 server, some clients cannot connect to the Exchange 2007 mail server. The POP3 service of the Exchange 2007 mail server may intermittently lose the response of the Exchange 2003 back-end server. Additionally, the Exchange 2007 mail server continues to try to respond to the Exchange 2003 back-end server until no more connection threads can be opened.

In this scenario, if a user tries to receive messages by using a POP3 mail client, the POP3 mail client may receive a 10061 error together with a 0x800CCC0E error code. Then, the Microsoft Exchange POP3 service must be restarted. Additionally, the following event is logged on the Exchange 2007 mail server:

Event Type: Warning
Event Source: MSExchangePOP3
Event ID: 1009
Description: Number of simultaneous connections made by user <xxx> exceeded maximum (16).

↑ Back to the top


Cause

This problem occurs if a deadlock occurs in the Microsoft.Exchange.POP3.exe process. In this situation, a client connection thread and a back-end proxy thread are pending for one another. Therefore, the existing connections are not disposed because the disposed threads are waiting for a resource that is held by the deadlocked threads. Eventually, the Exchange 2007 mail server reaches the connection limit.

Note The TCP/IP socket connections are closed. Only the connection objects and the counters are not disposed. Therefore, you cannot discover this problem by using the netstat command or by using the tcpview command.

↑ Back to the top


Resolution

To resolve this problem, install Update Rollup 3 for Exchange Server 2007. For more information about Update Rollup 3 for Exchange Server 2007, see the following Exchange Help topic: For more information about how to install the latest Exchange service pack or update rollup, see the following Exchange Help topic:

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For more information about the naming schema for Exchange Server software updates, click the following article number to view the article in the Microsoft Knowledge Base:
817903� New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB932905, kbqfe, kbexpertiseinter, atdownload

↑ Back to the top

Article Info
Article ID : 932905
Revision : 4
Created on : 8/31/2007
Published on : 8/31/2007
Exists online : False
Views : 392