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Resolve Hotkeys or Volume control keys not working on Microsoft keyboards


View products that this article applies to.

Symptoms

Hotkeys or the volume control keys do not work as expected on your Microsoft keyboard. Some hotkeys may behave as expected, but others do not.

You may receive an error message that resembles the following message when you try to start the Human Interface Service:
Error Code 126
Error 2

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Cause

This issue may occur if there is a problem with the USB connection on your computer. This issue can also occur if a third-party keyboard control utility is running on your computer. Examples of third-party keyboard control utilities are as follows:
  • Compaq Easy Access
  • E-machine's E-Board
  • Gateway MultiFunction Keyboard
  • Hewlett-Packard Multimedia Keyboard Utility
  • IBM Rapid Access •Logitech Key Commander
  • Packard Bell MediaSelect
Third-party keyboard control utilities are also provided with Acer, Gateway 2000, and Sony Multimedia computers.



This issue occurs because the scan codes issued by the keyboard are interpreted differently by each keyboard control utility. This can also be due to having unexpected default or re-defined program assignments for the keys. Many of the default assignments require that you have a specific program installed, or that you are using a supported e-mail program, Internet browser or media player.



If you do not have the supported program you can still use the key by reassigning the key.

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Resolution

Try each of the Methods below in order, testing the keys after each method. Proceed to the next method if the problem still occurs.

Method 1: Try a different USB Port

Connect the keyboard to a different USB port, and then check the behavior of the keyboard. (This method tests for port-specific issues.)

Note Bypass any port replicators, USB hubs, KVM switches, and so on. Connect the receiver directly to a port on the computer.

Method 2: Disable or uninstall any previously installed keyboard software

Disable any other keyboard control software installed on this computer and then try reassigning the keys.



For more information about how to assign functions to keys, click the following article number to view the article in the Microsoft Knowledge Base:

237179 Assign macro or function to keys on your keyboard



If the problem persists, remove any keyboard software on your computer. To uninstall any IntelliPoint, Logitech, or other keyboard software, follow these steps:
  1. Do one of the following things:
    • Windows Vista or Windows 7:
      1. Use the ARROW keys to locate the Start Search box, type appwiz.cpl, and then press ENTER.
      2. In the list of programs, use the ARROW keys to select Programs and Features, and then press ENTER.
      3. Use the ARROW keys to locate any keyboard controlling software, press TAB to locate Remove, and then press ENTER. If you have other mouse software installed, you may want to consider uninstalling that software also.
    • Windows XP and earlier versions of Windows:
      1. Click Start, click Run, type appwiz.cpl in the Open box, and then click OK.
      2. Use the ARROW keys to locate any keyboard controlling software, press TAB to locate Remove, and then press ENTER.
  2. Restart the computer if you are prompted to do this.
  3. Download the latest IntelliType software. For more information, visit the following Microsoft Web site:

Method 3: Restart the HID Human Interface Service

To fix this problem yourself, follow these steps:
  1. Open Microsoft Management Console (MMC) snap-in for Services.
    • In Windows Vista or Windows 7, click Start Start button , type services.msc in the Start Search box, and then press ENTER.

      User Account Control permission If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
    • In Windows XP, click Start, click Run, type services.msc in the Open box, and then click OK.
  2. In the list of services in the Details pane, double-click HID Human Interface Service, and then make sure that the Startup type is set to Automatic.
If you receive an error code when you try to start the HID Human Interface Service, try method 4. However, if you receive error code 126 or error code 2, try one of the following procedures:
  • If you receive error code 126, extract the Hidserv.dll file. To do this, follow these steps:
    1. Search for the Hidserv.dll on your system drive. If you cannot locate it on your system drive, locate the file on your Windows CD.
    2. Use the arrow keys to select Extract, and then press ENTER.
    3. Use the ARROW keys to select the folder C:\Windows\System32, and then select this folder as the destination.
    4. Restart the computer.
  • If you receive error code 2, change the registry settings. To do this, follow these steps.

    Note This issue may also occur because of changes in the registry settings.

    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
    322756 How to back up and restore the registry in Windows
    To resolve this problem, turn on HID services on the computer. To do this, follow these steps:
    1. Start Registry Editor.
      • In Windows Vista or Windows 7, click Start the Start button , type regedit in the Start Search box, and then press ENTER.

        User Account Control permission If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
      • In Windows XP, click Start, click Run, type regedit in the Open box, and then click
        OK.
    2. Locate and then click the following registry key:
      HKEY_LOCAL_MACHINE/System
    3. Expand System.
    4. Expand ControlSet001.
    5. Expand Services, and then click HidServ.
    6. In the right pane, right-click Type, and then click Modify.
    7. In the Value data box, make sure that the value is set to 20, and then click OK.
    8. Expand HidServ, and then click Parameters.

      Note If the Parameters registry key does not exist, follow these steps:
      1. Click HidServ.
      2. On the Edit menu, point to New, and then click Key.
      3. Type Parameters, and then press ENTER.
    9. In the right pane, right-click ServiceDll, and then click Modify.

      Note If the ServiceDll registry value does not exist, follow these steps:
      1. Click Parameters.
      2. On the Edit menu, point to New, and then click Expandable String Value.
      3. Type ServiceDll, and then press ENTER.
    10. In the Value data box, verify that the value is set to %SystemRoot%\System32\hidserv.dll. (Verify that there are no spaces before, after or in this value). If the value is not %SystemRoot%\System32\hidserv.dll, type %SystemRoot%\System32\hidserv.dll in the Value data box, and then click OK.
    11. Repeat steps 5 through 10 for each registry key that contains "ControlSet" in the key name. For example, if there is a registry key that is named CurrentControlSet or ControlSet002, click CurrentControlSet or click ControlSet002. Then, repeat steps 5 through 10.
    12. Exit Registry Editor, and then restart the computer.

Method 4: Test on a different computer

If the issue persists, test the keyboard with a different computer. If the keyboard does not work correctly with the other computer, contact our Order Desktop to obtain a replacement keyboard. To do this, call (800) 360-7561.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

326246 How to replace lost, broken, or missing Microsoft software or hardware

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Article Info
Article ID : 932875
Revision : 5
Created on : 2/6/2019
Published on : 2/6/2019
Exists online : False
Views : 332