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You are redirected to a different server or you are prompted for your credentials two times when you use Outlook Web Access to access an Exchange 2003 mailbox through Exchange 2007


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Symptoms

You try to access a Microsoft Exchange Server 2003 mailbox by using an Outlook Web Access connection to a Microsoft Exchange Server 2007 server that is running the Client Access Server (CAS) role. However, you experience one of the following symptoms:
The Web address of the Exchange 2003 mailbox server appears in the address bar of the Web browser.
You are prompted for your credentials two times before you can access the mailbox.
You receive the following error message in the Web browser:
The page cannot be displayed

Cannot find server or DNS error.

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Cause

This problem occurs if the Exchange 2007 server to which you connect is running the Mailbox role together with the CAS role.

In this scenario, the following behavior occurs:
If you specify the NetBIOS name of the Exchange 2007 server together with the /Exchange option, you are redirected to the Exchange 2003 mailbox server.
If you specify the fully qualified domain name (FQDN) of the Exchange 2007 server together with the /Exchange option, you are prompted for your credentials two times before you are redirected to the Exchange 2003 mailbox server
If you try to access the Exchange 2007 server from an external location, you receive a "The page cannot be displayed" error message.
When the CAS role is installed together with the Mailbox role, the /Exchange virtual directory uses the Davex.dll component for script mapping and not the Exprox.dll component. When only the CAS role is installed, Exchange 2007 uses Exprox.dll for script mapping for the /Exchange virtual directory when Exchange 2007 provides the proxy functionality.

The Davex.dll component cannot act as a proxy for the mailbox request. Therefore, Davex.dll redirects the request to the Exchange 2003 mailbox server. Additionally, if the request comes from an external location, Davex.dll cannot handle the request correctly. When you submit a request to the Exchange 2007 server from an external network, Exchange 2007 responds with a 302 Redirect response. However, because you do not have access to the Exchange 2003 server, the request cannot be redirected successfully. Therefore, you receive a "The page cannot be displayed" error message.

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Workaround

To work around this issue, deploy an Exchange 2007 server that is running without the Mailbox role.

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Keywords: KB932438, kbprb, kbtshoot, kberrmsg

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Article Info
Article ID : 932438
Revision : 1
Created on : 3/9/2007
Published on : 3/9/2007
Exists online : False
Views : 304