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FIX: Error message when you try to run a Web application that uses the "window.external" property in Internet Explorer 7: "Internet Explorer has encountered a problem and needs to close"


View products that this article applies to.

Symptoms

When you try to run a Web application that uses the window.external property in Windows Internet Explorer 7, you receive the following error message:
Internet Explorer has encountered a problem and needs to close. We are sorry for the inconvenience.

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Cause

This problem occurs because of a problem that is related to reference counting in MSHTML.

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Resolution

Security update information

To resolve this problem, install the most current cumulative security update for Internet Explorer. To do this, visit the following Microsoft Web site: For technical information about the most current cumulative security update for Internet Explorer, visit the following Microsoft Web site: Note This update was first included in the following security update:
MS08-031: Cumulative Security Update for Internet Explorer (950759)
For more information about this security update, click the following article number to view the article in the Microsoft Knowledge Base:
950759 MS08-031: Cumulative security update for Internet Explorer

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Ieframe.dll7.0.6000.205196,054,40022-Jan-200723:53x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB931324, kbqfe, kbbug, kbfix, kbprb, kbexpertiseinter, kbvistasp1fix

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Article Info
Article ID : 931324
Revision : 6
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 295