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Error message when you try to accept a meeting request on behalf of an Exchange Server 2007 resource mailbox: "Cannot open Calendar folder for user resource_mailbox_name"


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Symptoms

When you try to accept a meeting request on behalf of a Microsoft Exchange Server 2007 resource mailbox, you may receive one of the following error messages:
Error message 1
Cannot open Calendar folder for user resource_mailbox_name. The operation failed.
Error message 2
Cannot open the free/busy information. You do not have permission to create a subfolder in this folder.
Additionally, you cannot open items that are in the Calendar folder of the resource mailbox. When you try to open an item that is in the Calendar folder, you receive the following error message:
Cannot open this item. Cannot open the free/busy information. You do not have sufficient permission to perform this operation on this object. See the folder contact or your system administrator.
However, you can open the Calendar folder of the resource mailbox.

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Cause

This issue occurs if the following conditions are true:
  • You are a delegate for the resource mailbox.
  • You have insufficient permissions to the resource mailbox.
If the delegate has insufficient permissions to the resource mailbox, the delegate cannot respond to meeting requests, nor can the delegate view calendar items. This situation can occur if an administrator used the -ResourceDelegates parameter of the Set-MailboxCalendarSettings shell command to set permissions on the resource mailbox.

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Resolution

To resolve this problem, use one of the following methods.

Method 1: Provide full mailbox access for the resource mailbox to the delegate

To provide full mailbox access for the resource mailbox to the delegate, follow these steps:
  1. Click Start, point to All Programs, point to Microsoft Exchange Server 2007, and then click Exchange Management Shell.
  2. Type the following command, and then press ENTER:
    Add-MailboxPermission Resource_Mailbox_Alias -AccessRights:fullaccess -User:Delegate_Alias
  3. If the delegate is currently logged on to Microsoft Outlook, make sure that they exit and then restart Outlook.

Method 2: Modify the free/busy permissions for the resource mailbox

To modify the free/busy permissions for the resource mailbox, follow these steps:
  1. Click Start, point to All Programs, point to Microsoft Exchange Server 2007, and then click Exchange Management Shell.
  2. Type the following command, and then press ENTER:
    Add-MailboxPermission Resource_Mailbox_Alias -AccessRights:fullaccess -User:Resource_Administrator_Alias
  3. Create a Microsoft Office Outlook 2007 profile for the resource mailbox.
  4. Start Outlook 2007 with this new profile, and then provide the resource_administrator_alias credentials when you are prompted.
  5. In the Navigation Pane, click the Folder List icon, right-click the Calendar folder, and then click Properties.
  6. On the Permissions tab, make sure that the Permission level for the delegate is set to at least Editor, and then click OK.
  7. Exit Outlook 2007.

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Keywords: KB930865, kbprb, kbtshoot, kbexpertiseadvanced

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Article Info
Article ID : 930865
Revision : 3
Created on : 5/10/2007
Published on : 5/10/2007
Exists online : False
Views : 372