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Users who do not use Exchange Server experience delayed responses when they query free/busy data for users who were migrated to Exchange Server 2007


View products that this article applies to.

Symptoms

Users who do not use Microsoft Exchange Server query free/busy data for users who were migrated to Microsoft Exchange Server 2007. When they do this, they experience delayed responses.

For example, Lotus Notes users query the free/busy data of users who previously used Notes but who have been migrated to Exchange Server 2007. When this occurs, the Notes users experience delayed responses.

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Cause

This problem occurs when the Exchange Migration Wizard does not remove the additional properties in the free/busy data of a migrated user at the time of the migration.

Note To prevent this problem on Notes accounts that you want to migrate, use the latest Web release version of the Microsoft Exchange Server 2003 Migration Wizard for Lotus Notes.
The following file is available for download from the Microsoft Download Center:
Download the NotesMig.exe package now. Release Date: June 6, 2007

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

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Workaround

To work around this problem for accounts that you have already migrated, you must manually delete the additional properties in the free/busy data of the migrated user by using the MFCMAPI tool. To do this, follow these steps.

Step 1: Locate the free/busy data

The free/busy public folder for a particular site or for an administrative group is located in the following path:
Public Folders\NON_IPM_SUBTREE\Schedule+ Free Busy\EX:/O=Organization Name/OU=Administrative Group Name
A message in the following format may indicate that free/busy data is available for that object:
User-/cn=Recipients/CN=alias
The following additional properties may exist for an affected user:
  • 0x7AE0001E - PT_STRING8

    This property contains the migrated user's target address. For example, for a migrated Notes user, this field contains the following data:
    NOTES:Notes User/Notes Domain@Notes Organization
  • 0x7AE10040 - PT_SYSTIME

    This property contains the date and the time when the last update of the user's free/busy data occurred. For example, this field may contain the following data:
    01:30:00 PM 09/22/2006 12:00:00 AM 01/01/1601
    Note The "1601" entry in the date indicates that free/busy data was not gathered.
  • 0x7AE20003 - PT_LONG

    This property contains information about the migrated user's time zone.

Step 2: Use the MFCMAPI tool to remove the additional properties in the free/busy data

To do this, follow these steps:
  1. Download the MFCMAPI tool, and then copy it to the server that is running Exchange Server. The following file is available for download from the Microsoft Download Center:
    Download the MfcMapi.exe package now. Release Date: June 7, 2006

    For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
    119591 How to obtain Microsoft support files from online services
    Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.
  2. Start the MFCMAPI tool.
  3. On the Session menu, click Logon and Display Store Table.
  4. On the MDB menu, click Open Public Folder Store, and then click OK.
  5. Expand Public Root, expand NON_IPM_SUBTREE, and then expand SCHEDULE + FREE BUSY.
  6. Double-click the site or the administrative group object that you want. For example, double-click the EX:/o=First Organization/ou=First Administrative Group object.
  7. In the upper pane, click a message that contains the following entry:
    User-/cn=Recipients/CN=GUID
  8. In the bottom pane, click the following properties, and then press DELETE:
    • 0x7AE0001E - PT_STRING8
    • 0x7AE10040 - PT_SYSTIME
    • 0x7AE20003 - PT_LONG
  9. Exit the MFCMAPI tool.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

About the function of the calendar connector

Note In this section, the term "third-party calendar connector" means a connector such as the Calendar Connector for Lotus Notes or the Calendar Connector for Novell GroupWise.

A third-party calendar connector performs several different operations.

Accepts notifications from the Store.exe process

The connector accepts notifications from a user who requests free/busy data for a third-party user.

After a notification is received, the third-party calendar connector retrieves free/busy data from the third-party system. Then, the connector puts the data in a free/busy message in the public folder store.

When this process is complete, or when the time-out period has expired, the free/busy data is returned to the requesting client.

Responds to requests from third-party users

The connector responds to third-party systems that request free/busy data about Exchange Server users.

The third-party calendar connector resolves the third-party address of the requested user. Then, the connector performs a lookup operation against a public folder that contains the schedule information. This information is converted to the correct format for the third-party system. Then, the information is returned to the requesting client.

Synchronizes the list of third-party users from the Active Directory directory service

The calendar connector synchronizes the list of third-party contacts to the free/busy public folder that is named Calsync. This synchronization first occurs when the calendar connector first starts. Later, if the setting on the Schedule tab of the Properties page of the third-party calendar connector is configured to Always, the synchronization occurs every 15 minutes.

The third-party calendar connector searches for users who are synchronized by using the Directory Synchronization (DirSync) services of the connector. Then, the third-party calendar connector creates new free/busy messages for each user or contact.

How it is determined that the free/busy query is for a third-party user

The Store.exe process determines whether a free/busy message is for a third-party user by determining whether additional properties exist in the free/busy message. If additional properties exist, the query is directed to the calendar connector service to retrieve the third-party user's data.

Why users experience delayed responses

Typically, when a user who does not use Exchange Server is migrated to Exchange Server, the Migration Wizard tries to match the user's free/busy message. Additionally, the wizard tries to remove the additional properties.

However, in some cases, the migrated user may not be correctly matched to the Exchange Server contact. Therefore, the additional properties are not removed.

Matching may not occur in the following cases:
  • You use a third-party migration wizard

    Third-party migration tools may not correctly match the user. Additionally, third-party tools may not remove the additional properties even if the user is correctly matched.
  • The Exchange Migration Wizard does not correctly match the user

    The first time that a migrated user is synchronized to Active Directory, the synchronization is processed by the Directory Synchronization service (DirSync). When the user is migrated to a container that differs from the container that was used by DirSync, the Exchange Migration Wizard may not correctly match the user to the Exchange Server contact.
When the additional properties of a migrated user's free/busy message are not removed, the Microsoft Exchange Information Store service resolves the user as a non-Exchange user. Then, the service passes the query to the Exchange Calendar Connector.

In turn, the Exchange Calendar Connector queries the calendar connector of the non-Exchange system. This procedure causes the delay in retrieving free/busy data.

For more information about the terminology that Microsoft uses for software that is corrected after it is released, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about the naming schema for Exchange software updates, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: KB928874, kbbug, kbfix, atdownload, kbcalendar, kbmigrate, kbexpertiseadvanced, kbarchive, kbnosurvey

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Article Info
Article ID : 928874
Revision : 3
Created on : 1/16/2015
Published on : 1/16/2015
Exists online : False
Views : 401