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Error message when you try to mount the public folder store in Exchange 2000: "An internal processing error has occurred. ID no: c1041724"


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Symptoms

When you try to mount the public folder store in Microsoft Exchange 2000 Server, you experience the following symptoms:
  • You receive the following error message:
    An internal processing error has occurred. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.

    ID no: c1041724
    Exchange System Manager
  • If you right-click Public Folder Store (ServerName) in Exchange System Manager, and then click Properties, the Associated public folder tree box is blank.

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Cause

This problem occurs if an incorrect value is set for the msExchOwningPFTree attribute in the Active Directory directory service.

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Resolution

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

To resolve this issue, verify the value of the msExchOwningPFTree attribute in Active Directory. If this value is not set, or if this attribute has an incorrect value, specify the correct value. To do this, follow these steps.

Step 1: Determine the correct value for the msExchOwningPFTree attribute

  1. Start the ADSI Edit tool. To do this, click Start, click Run, type adsiedit.msc, and then click OK.

    Note The ADSI Edit tool is included with the Windows 2000 Support Tools. To install the Windows Support Tools, double-click Setup.exe in the Support\Tools folder on the Microsoft Windows 2000 Server CD.
  2. In the ADSI Edit Microsoft Management Console (MMC) snap-in, expand Configuration Container [domainControllerName.example.com].
  3. Expand CN=Services, expand CN=Microsoft Exchange, expand CN=OrganizationName, expand CN=Administrative Groups, and then expand the administrative group. For example, expand CN=First Administrative Group.

    Note If Exchange is installed in a mixed organization, the administrative group has the same name as the Microsoft Exchange Server 5.5 site.
  4. Click Folder Hierarchies, right-click CN=Public Folders in the right pane, and then click Properties.
  5. In the CN=Public Folders Properties dialog box, click distinguishedName in the Select a property to view list.
  6. Copy the value that appears in the Value(s) box, and then click Cancel.

Step 2: Set the correct value for the msExchOwningPFTree attribute

  1. Start the ADSI Edit tool.
  2. In the ADSI Edit Microsoft Management Console (MMC) snap-in, expand Configuration Container [domainControllerName.example.com].
  3. Expand CN=Services, expand CN=Microsoft Exchange, expand CN=OrganizationName, expand CN=Administrative Groups, and then expand the administrative group.
  4. Expand CN=Servers, expand CN=Exchange 2000 server, expand CN=InformationStore, and then expand CN=First Storage Group.
  5. In the right pane, right-click CN=Public Folder Store (Exchange 2000 server), and then click Properties.
  6. In the CN=Public Folder Store (Exchange 2000 server) Properties dialog box, click msExchOwningPFTree in the Select a property to view list.
  7. Examine the value that is displayed in the Value(s) box, and then perform one of the following actions:
    • If <not set> appears in the Value(s) box, follow these steps:
      1. Paste the LDAP path that you copied in "Step 1: Determine the correct value for the msExchOwningPFTree attribute" into the Edit Attribute box, and then click Set.
      2. Click Apply, and then click OK.
    • If an incorrect value appears in the Value(s) box, follow these steps:
      1. Click Clear, and then delete the contents of the Edit Attribute box.
      2. Paste the LDAP path that you copied in "Step 1: Determine the correct value for the msExchOwningPFTree attribute" into the Edit Attribute box, and then click Set.
      3. Click Apply, and then click OK.
  8. Exit the ADSI Edit tool.
  9. Stop and then start the Microsoft Exchange Information Store service.

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Keywords: KB926207, kbprb, kberrmsg, kbtshoot

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Article Info
Article ID : 926207
Revision : 2
Created on : 11/13/2006
Published on : 11/13/2006
Exists online : False
Views : 220