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When you access a server that is running Exchange Server 2003 or Exchange 2000 Server from a remote site, the server may stop responding


View products that this article applies to.

Symptoms

When you access a server that is running Microsoft Exchange Server 2003 or Microsoft Exchange 2000 Server from a remote site, the server may stop responding after some time. You have to restart the server to resume the Exchange services.

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Cause

This problem occurs if the following conditions are true:
  • The Exchange server has to access user rights information from domain controllers in the remote site over a WAN connection.
  • The WAN connection to the remote site works intermittently. Or, the WAN connection has a low bandwidth.
When you access a server that is running Exchange Server 2003 or Exchange 2000 Server from a remote site, the Exchange server may try to access an authoritative domain controller in your home domain to receive user rights information. If the WAN connection is not working, the LDAP queries will time out. However, if the WAN connection is intermittent or has a low bandwidth, the LDAP queries that are waiting for a response accumulate. These queries cause the server to run out of threads. Therefore, the server stops responding.

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Resolution

Hotfix information

Microsoft Exchange Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you install the hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003
Restart requirement
You do not have to restart the computer after you apply the hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Dsaccess.dll6.5.7650.25637,95218-Jan-200604:30x86

Microsoft Exchange 2000 Server

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must install Microsoft Exchange 2000 Server Service Pack 3 (SP3) and the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup before you install the hotfix.

For more information about how to obtain both these software updates, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack
Restart requirement
You do not have to restart the computer after you apply the hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Dsaccess.dll6.0.6619.5577,53622-Feb-200606:19x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

After you install this hotfix, the default time-out period for LDAP threads is reduced to 30 seconds. If you want to change the default time-out period, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\Services\MSExchangeDSAccess
  3. Double-click the LdapBindTimeoutSecs registry entry.

    Note The LdapBindTimeoutSecs registry entry is a DWORD value.
  4. In the Value data box, type the value that you want to use for the time-out period. For example, if you want the time-out period to be 25 seconds, type 25.
This hotfix resolves the problem that is described in this article. The hotfix will not resolve a problem in which the Exchange server cannot access local domain controllers when the connections to these domain controllers are not working. In this scenario, you must troubleshoot the connections to the local domain controllers.

Information about changes to the Send As user right in post-Exchange Server 2003 SP2 hotfixes

After Exchange Server 2003 SP2 was released, a change was made to the security behavior of the Exchange Server information store. This change concerns how users assign the Send As user right. This change is included in all post-Exchange Server 2003 SP2 hotfixes that are version 6.5.7650.23 or later.

Before this change was made, if you assigned Full Mailbox Access user rights to a service account, the service was able to send messages as the owner of the mailbox in some circumstances. After this change was made, mailbox security granularity now requires that you explicitly assign the Send As user right.

Many third-party add-in programs and services send messages for Exchange Server users. These programs and services include mobile device synchronization services. These programs and services may not have been granted Send As user rights. Instead, they may rely on Full Mailbox Access user rights. After you apply this hotfix, a program or a service may no longer function correctly because the program or service account can no longer send messages for other users.

For more information about how to assign the Send As user right to an account, click the following article number to view the article in the Microsoft Knowledge Base:
912918 Error message when an application tries to send a message as another user by using Exchange Server 2003:"Access denied"
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

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Keywords: kbnosurvey, kbautohotfix, kbexchange2000presp4fix, kbHotfixServer, kbqfe, kbfix, kbbug, kbarchive, KB911830

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Article Info
Article ID : 911830
Revision : 3
Created on : 1/14/2015
Published on : 1/14/2015
Exists online : False
Views : 278