Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you browse a database results page in FrontPage 2003: "Database Results Wizard Error. The database connection named 'DATABASE1' is undefined"


View products that this article applies to.

Symptoms

You use the Database Results Wizard to create a database results page in Microsoft Office FrontPage 2003. When you try to browse this database results page, you receive an error message that is similar to the following:
Database Results Wizard Error

The database connection named 'DATABASE1' is undefined.

↑ Back to the top


Cause

This issue occurs if the following conditions are true:
You converted a sub Web to a folder. However, you created a database connection in the sub Web before you converted the sub Web to the folder.

Note The application root for the sub Web is not automatically removed when you convert the sub Web to a folder.
You created an instance of the Database Results Wizard in a new page in the folder that you created in step 1.
When you browse the database results page, the Active Server Page (ASP) page tries to access the Global.asa file in the folder that you created instead of in the root folder of the Web site. This behavior occurs because the ASP page always tries to access the Global.asa file from a folder if the following conditions are true:
The folder contains the ASP page.
The folder is the application root.

↑ Back to the top


Resolution

To resolve the issue, follow these steps:
1.Remove the application root from the folder that you converted from a sub Web. To do this, follow these steps:
a. Click Start, click Run, type inetmgr in the Open box, and then click OK.
b. Expand the root site, right-click the folder from which you want to remove the application root, and then click Properties.
c. Click the Directory tab, click Remove in the Application settings field, and then click OK.
2.Open the Global.asa file in Microsoft FrontPage.
3.Save the Global.asa file back to the content folder, restart the Microsoft Internet Information Services (IIS), and then test the form.

To restart IIS, follow these steps:
a. Click Start, click Run, type cmd in the Open box, and then click OK.
b. At the command prompt, type iisreset, and then press ENTER.

↑ Back to the top


More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
265174 "Connection Undefined" error when you view an Active Server Page in the Web Browser
292628 Database connection undefined after publishing Web

↑ Back to the top


Keywords: KB909502, kbprb, kbtshoot

↑ Back to the top

Article Info
Article ID : 909502
Revision : 2
Created on : 12/15/2005
Published on : 12/15/2005
Exists online : False
Views : 291