Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Some e-mail messages are not delivered, and message senders may receive an NDR message in Exchange 2000 Server


View products that this article applies to.

Symptoms

Consider the following scenario. You enable the Filter messages with blank sender feature in the Message Delivery properties in Microsoft Exchange 2000 Server. Additionally, you enable the Apply Filter feature on the Simple Mail Transfer Protocol (SMTP) virtual server. After you enable the Apply Filter feature, some messages that are sent by users are not delivered by the server that is running Exchange 2000 Server. Additionally, message senders may receive a non-delivery report (NDR) message that includes an error message. The error message is similar to the following error message:
554 5.1.0 Sender Denied

↑ Back to the top


Cause

This behavior occurs if the message that was sent has a blank From field in the message header.

↑ Back to the top


Resolution

To resolve this behavior, make sure that your messages have the From field populated.

↑ Back to the top


Workaround

To work around this behavior, disable the Apply Filter feature on the appropriate SMTP virtual server. To do this, follow these steps:
  1. Start Exchange System Manager.
  2. Expand Administrative Groups, expand Your_Administrative_Group, and then expand Your_Server.
  3. Expand Protocols, expand SMTP, right-click Your_SMTP_Virtual_Server, and then click Properties.
  4. On the General tab, click Advanced.
  5. In the IP address list, click the appropriate IP address, and then click Edit.
  6. Click to clear the Apply Filter check box.
  7. Click OK three times.
  8. Quit Exchange System Manager.
  9. In the Service snap-in, restart the Microsoft Exchange Routing Engine service and the Simple Mail Transfer Protocol (SMTP) service.

↑ Back to the top


More information

Messages that have a blank From field are not delivered in Exchange 2000 Server. This behavior occurs even if the message has other valid originator fields. Valid originator fields include the following fields:
  • Sender
  • ResentFrom
  • ResentSender

↑ Back to the top


Keywords: KB907973, kbprb, kbtshoot

↑ Back to the top

Article Info
Article ID : 907973
Revision : 2
Created on : 10/27/2006
Published on : 10/27/2006
Exists online : False
Views : 220