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Error message when you try to open certain e-mail messages from an Exchange 2000 Server mailbox: "Message could not be opened"


View products that this article applies to.

Symptoms

When you try to open certain e-mail messages from a Microsoft Exchange 2000 Server mailbox, you receive the following error message:
Message could not be opened.
If you use Microsoft Outlook Web Access, or a different e-mail client program, to open those same e-mail messages, the e-mail messages open successfully.

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Cause

This problem occurs if the e-mail message contains malformed HTML code. Specifically, this problem occurs if one of the following conditions is true:
  • The HTML code contains unbalanced sets of quotation marks ("").
  • The HTML code contains contiguous double quotation marks.
For example, this problem may occur if the e-mail message contains malformed HTML code that is similar to the following:
<td width="60%"" valign="bottom" class="t1" style="text-align:right;padding-right:10px; align="right">
In this code example, contiguous double quotation marks incorrectly appear after the following part of the example code:
60%
Additionally, because no closing double quotation mark appears after the following part of the example code, the quotation marks are not a balanced set:
style="text-align:right;padding-right:10px;
Therefore, Exchange 2000 Server tries to keep parsing the malformed HTML code. Because of this behavior, the Microsoft Outlook client program may be unable to open the e-mail message that contains this malformed HTML code.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, you must have both of the following packages installed to apply this hotfix:
  • Microsoft Exchange 2000 Server Service Pack 3 (SP3).

    For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    301378� How to obtain the latest Exchange 2000 Server service pack
  • The August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup.

    For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    870540� Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the Microsoft Exchange Information Store service and all the services that depend on the Microsoft Exchange Information Store service are automatically stopped and then restarted when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mdbmsg.dll6.0.6617.942,342,91201-Nov-200503:07x86
Store.exe6.0.6617.944,714,49601-Nov-200503:58x86

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More information

Exchange 2000 Server uses the following steps to parse the code example that appears in the "Cause" section:
  1. An HTML e-mail message contains the following tag:
    <td width="60%"" valign="bottom" class="t1" style="text-align:right;padding-right:10px; align="right">
    
  2. Exchange 2000 Server ignores the contiguous quotation mark when it first parses the HTML code. Therefore, Exchange 2000 Server treats the input HTML code as follows:
    <td width="60%"  valign="bottom" class="t1" style="text-align:right;padding-right:10px; align="right">
  3. This leaves the HTML code with an unbalanced set of quotation marks. In this situation, Exchange 2000 Server expects a closing double quotation mark to appear after the last angle bracket (>) in this code.
  4. Because this is an unbalanced quotation mark situation, Exchange 2000 Server tries to establish a balanced quotation mark state. Therefore, Exchange 2000 Server counts each quotation mark in the HTML code. Exchange 2000 Server treats the HTML code as follows:
    <td width="60%"" valign="bottom" class="t1" style="text-align:right;padding-right:10px; align="right">
In this situation, Exchange 2000 Server detects 10 double quotation marks. Therefore, Exchange 2000 Server determines that the quotation marks in the HTML code are in a balanced state. Then, Exchange 2000 Server continues to try to parse the malformed HTML code.

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Keywords: KB907254, kbpubtypekc, kbbug, kbexchange2000presp4fix, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 907254
Revision : 6
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 389