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Users may not be able to print 3270 print jobs through the SNA Print service in Host Integration Server


View products that this article applies to.

Symptoms

In Microsoft Host Integration Server, users may not be able to print 3270 print jobs through the SNA Print service (Snaprint.exe). This problem occurs even though the 3270 print sessions are in an Insession state in SNA Manager. Error messages that are similar to the following are logged in the application event log when this problem occurs:

Event ID: 9
Source: SNA Virtual Print Driver
Description: The GDI routine OpenPrinter has returned an error to the SNA Virtual Print Driver.

Error returned: error code
Printer: printer name


Event ID: 21
Source: SNA Server
Description:
(1124) Negative Response Sent on Connection connection name (SENSE = 814)

SUBCODE INFORMATION X'1124'
A negative response was sent and logged. This error normally follows a more specific error message, depending on the type of negative response sent and its cause. The SNA sense data provides details about the type of error.

Additionally, the affected 3270 printer Logical Units (LU) will have a status of ACTIVE-P(ending) when you view the LUs in Virtual Telecommunications Access Method (VTAM) on the IBM mainframe.

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Cause

The problem occurs when the SNA Print service loses its connection to the physical printer that is defined for a 3270 print session. The connection is lost between the time that a BIND is received for a 3270 print job and the time that actual print data is sent by the mainframe application. The SNA Print service only tries to reconnect to a printer one time for 3270 print sessions when the SNA Print service loses the connection to the physical printer. If the retry attempt fails, the 3270 print session stays in an Insession state. The mainframe application cannot spool print jobs to the print session.

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Resolution

Host Integration Server 2000

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size     File name
   -----------------------------------------------------
   08-Aug-2005  22:32  5.0.0.2075      250,128  Ppd3270.dll
   08-Aug-2005  22:32  5.0.0.2075      282,896  Winvprt.dll

				
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

Host Integration Server 2004

A hotfix is not currently available for Host Integration Server 2004.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

After you apply the update, the SNA Print service will try to reconnect to the physical printer every 12 seconds until the connection to the printer is successful. An Event ID 9 message that is similar to the one described in the "Symptoms" section will be logged for each retry attempt that fails. The SNA Print service will stop trying if the mainframe application sends a CLEAR request unit (RU) or an UNBIND RU to end the outstanding print job.

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Keywords: kbautohotfix, kbqfe, kbhis2000, kbhis2004, kbfix, kbbug, kbpubtypekc, kbhotfixserver, KB905396

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Article Info
Article ID : 905396
Revision : 8
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 393