Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Use of the WebDAV protocol to retrieve an .xls file attachment in an e-mail message causes a file handle leak in Exchange 2000 Server


View products that this article applies to.

Symptoms

Consider the following scenario. You use a program that uses the GET method in the Web-based Distributed Authoring and Versioning (WebDAV) protocol in a Microsoft Exchange 2000 Server organization. This program retrieves an attachment from an e-mail message. The attachment is a Microsoft Excel (.xls) file.

In this scenario, you may experience the following symptoms:
The performance of the Exchange 2000 Server server deteriorates over a period.
You have to restart the Exchange 2000 Server server to resume typical performance levels.
Additionally, you find that there is a continuous increase in the number of file handles that are allocated to the Store.exe process.

↑ Back to the top


Cause

This problem occurs because Exchange 2000 Server leaks a file handle every time that the WebDAV GET method is executed.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must install Microsoft Exchange 2000 Server Service Pack 3 (SP3), before you install the hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack

Restart requirement

You do not have to restart your computer after you apply the hotfix. However, Microsoft Exchange System Attendant and all dependent services will be restarted.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   --------------------------------------------------
   16-Jul-2005  06:42  6.0.6617.79     2,342,912  Mdbmsg.dll       
   18-Jul-2005  22:34  6.0.6617.79     4,710,400  Store.exe
				

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB900406, kbpubtypekc, kbbug, kbexchange2000presp4fix, kbfix, kbhotfixserver, kbqfe

↑ Back to the top

Article Info
Article ID : 900406
Revision : 4
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 260