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You receive a "Cannot open DLL 'stsnwi.dll'" error message when you try to open a Web site in FrontPage 2003


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Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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Symptoms

When you try to open a Web site in Microsoft Office FrontPage 2003, you receive the following error message:
Cannot open DLL "stsnwi.dll"
After you click OK to close the error message, you cannot open any other Web sites in FrontPage 2003.

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Cause

This issue occurs if the following registry entry has been set with a value of 2:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\Web Extender Client\wecctlflags
Earlier versions of Microsoft FrontPage used the wecctflags registry entry to bypass the connectivity features and the libraries of Microsoft Internet Explorer. This behavior allowed for the use of the Internet connectivity features and the Internet libraries that were built in to the earlier versions of FrontPage.

However, FrontPage 2003 does not have these local libraries available for use. To function as expected, FrontPage 2003 must use the libraries that are provided by Internet Explorer. Therefore, when the wecctlflags registry entry is present, you may receive the error message that is mentioned in the "Symptoms" section.

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Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this issue, remove the wecctlflags registry entry. Follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click to select the following registry key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\Web Extender Client\wecctlflags
  3. On the Edit menu, click Delete.
  4. Quit Registry Editor.

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Keywords: KB899708, kbprb, kbtshoot, kbregistry, kbopenfile, kbwininternet, kbdll

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Article Info
Article ID : 899708
Revision : 5
Created on : 2/19/2006
Published on : 2/19/2006
Exists online : False
Views : 279