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After you install security update 885250 (MS05-011), you may not be able to view the contents of a subfolder on a network share by using Windows XP or Windows Server 2003


View products that this article applies to.

Symptoms

On a computer that is running Microsoft Windows XP Service Pack 1 (SP1) or Microsoft Windows Server 2003, you use one of the following methods to try to view the contents of a subfolder on a network share:
  • You use the dir command-line command to view the contents of a subfolder on a network share.
  • You use Microsoft Windows Explorer to view the contents of a subfolder on a network share.
When you use either of these methods, you cannot view the contents of subfolders or you can only view a partial list of files. Additionally, some files are not viewable. When you try to view the files, you receive the following error message:
File not found
Note This symptom does not occur if you try to view the root folder of the network share.

Other behavior that you may see

When you experience the symptom that is described in the "Symptoms" section, you may also notice the following behavior.
  • Domain users who log on to their Windows XP-based clients cannot load their roaming profiles. These users are logged on with a temporary profile. Windows XP may log one or more of the following messages in the Application event log:

    Event ID: 1509
    Raw Event ID: 1509
    Record Nr.: 224
    Category: None
    Source:�Userenv
    Description: Windows cannot copy file \\domainname.net\users\Profile\username\Application Data\Microsoft\ to location C:\Documents and Settings\username\Application Data\Microsoft\. Possible causes of this error include network problems or insufficient security rights. If this problem persists, contact your network administrator. DETAIL - The specified server cannot perform the requested operation.

    Event Type:�Error
    Event Source:�Userenv
    Event Category: None
    Event ID:�1521
    Description: Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Possible causes of this error include network problems or insufficient security rights. If this problem persists, contact your network administrator. DETAIL - Windows cannot find the network path. Verify that the network path is correct and the destination computer is not busy or turned off. If Windows still cannot find the network path, contact your network administrator.

  • The Userenv.log file may contain the following errors:
    USERENV RecurseDirectory: Adding F:\Profile\username\Application Data\Identities\{1B28C879-03B9-4263-B0E7-E82D7EA7FAD6}\ to the list of directories
    USERENV RecurseDirectory: Adding F:\Profile\username\Application Data\Identities\ to the list of directories
    USERENV RecurseDirectory: FindFirstFile failed. Error = 58
    USERENV ReportError: Impersonating user.
    USERENV GetShareName: WNetGetConnection initially returned error 2250
    Note Error 58�is equivalent to the "ERROR_BAD_NET_RESP The specified server cannot perform the requested operation" error message. Error 2250 is equivalent to the "ERROR_NOT_CONNECTED This network connection does not exist" error message.

    This problem occurs if the following conditions are true:
    • You have installed the redirector software update 885250 or a later version of the redirector software update. Update 885250 is described in Microsoft security bulletin MS05-11.
    • The following flag is enabled on the users profile share of the Profile server:
      SHI1005_FLAGS_ALLOW_NAMESPACE_CACHING

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Cause

This symptom occurs if all the following conditions are true:
  • You have installed the security update 885250 (MS05-011), or you have installed a later redirector software update.
  • The following registry information is true for the operating system that you are using:
    • Windows XP:
      • The server that you are connecting to is running Microsoft Windows XP and the following registry entry value is set to 1 on the server:

        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation
        Value Type: DWORD
        Value Data: 1

        Note By default, the value for this registry entry is set to 0 (zero).
    • Windows Server 2003
      • The server you are connecting to is running Microsoft Windows Server 2003 and the following registry entry value is set to 1 on this server:

        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\NoAliasingOnFileSystem
        Value Type: DWORD
        Value Data: 1

        Note By default, the value for this registry entry is set to 0 (zero).
  • You try to view the contents of a subfolder that is in the root folder of the network share.

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Resolution

Update information

To download this update from the Microsoft Download Center, visit one of the following Microsoft Web sites.

Client computers that have Windows XP Service Pack 1 or Windows XP Service Pack 2 installed

Client computers that have Windows Server 2003 installed

Client computers that have Windows Server 2003, Enterprise Edition for Itanium-based Systems or Windows Server 2003, Datacenter Edition for Itanium-based Systems installed

Prerequisites

To apply this update on a computer that is running Windows XP, you must have Service Pack 1 or Service Pack 2 installed.

Note There are no prerequisites for installing this update on a computer that is running Windows Server 2003.

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP with Service Pack 1, Windows XP with Service Pack 2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Cscdll.dll5.1.2600.159992,16028-Oct-200401:29x86SP1SP1QFE
Mrxsmb.sys5.1.2600.1762431,61615-Oct-200500:31x86SP1SP1QFE
Rdbss.sys5.1.2600.1599170,11212-Oct-200416:22x86SP1SP1QFE
Mrxsmb.sys5.1.2600.2778451,71217-Oct-200523:51x86SP2SP2GDR
Mrxsmb.sys5.1.2600.2778452,86417-Oct-200523:54x86SP2SP2QFE
Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatformService branch
Mrxsmb.sys5.2.3790.428394,24019-Oct-200523:37x86RTMGDR
Mrxsmb.sys5.2.3790.428395,77619-Oct-200523:45x86RTMQFE
Rdbss.sys5.2.3790.221158,20812-Oct-200400:29x86RTMQFE
Windows Server 2003, Enterprise Edition for Itanium-based Systems
File nameFile versionFile sizeDateTimePlatformService branch
Mrxsmb.sys5.2.3790.4281,122,81619-Oct-200508:25IA-64RTMGDR
Mrxsmb.sys5.2.3790.4281,125,37619-Oct-200508:45IA-64RTMQFE
Rdbss.sys5.2.3790.221464,89611-Oct-200409:30IA-64RTMQFE

Note When you install this software update on a Windows XP SP2-based computer or on a Windows Server 2003-based computer, the installer checks to see whether one or more of the files that are being updated on your computer have previously been updated by a Microsoft hotfix. If you have previously installed a hotfix to update one of these files, the installer copies the RTMQFE files to your computer. Otherwise, the installer copies the RTMGDR files to your computer. For more information about the contents of Windows XP Service Pack 2 and Windows Server 2003 software update packages, click the following article number to view the article in the Microsoft Knowledge Base:
824994 Description of the contents of Windows XP Service Pack 2 and Windows Server 2003 software update packages

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbwinserv2003sp2fix, kbqfe, kbhotfixserver, atdownload, kbwinxpsp3fix, kbwinxppresp3fix, KB896427

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Article Info
Article ID : 896427
Revision : 18
Created on : 3/28/2007
Published on : 3/28/2007
Exists online : False
Views : 597