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Event ID 9074, event ID 2070, event ID 9154, event ID 2069, or event ID 2075 may be logged on a computer that is running Exchange server


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Symptoms

You may experience any one or more of the following symptoms:
  • When you try to start the Microsoft Exchange System Attendant service, the system attendant does not start.
  • Microsoft Outlook clients cannot log on to the Microsoft Exchange server.
  • The following event ID messages are logged in the application event log:


    Event Type: Error
    Event Source: MSExchangeSA
    Event Category: RFR Interface
    Event ID: 9074
    Date: Date
    Time: Time
    User: N/A
    Computer: Computer_Name
    Description: The Directory Service Referral interface failed to service a client request. RFRI is returning the error code:[0x3f0. For more information, click http://search.support.microsoft.com/search/?adv=1.


    Event Type: Warning
    Event Source: MSExchangeDSAccess
    Event Category: None
    Event ID: 2070
    Date: Date
    Time: Time
    User: N/A
    Computer: Computer_Name
    Description: Process MAD.EXE (PID=1528). Dsaccess lost contact with domain controller Domain_Controller_Name. Error was 80040951. Dsaccess will attempt to reconnect with this domain controller when it is reachable. For more information, click http://search.support.microsoft.com/search/?adv=1.


    Event Type: Error
    Event Source: MSExchangeSA
    Event Category: General
    Event ID: 9154
    Description: DSACCESS returned an error '0x80070862' on DS notification. Microsoft Exchange System Attendant will re-set DS notification later.


    Event Type: Error
    Event Source: MSExchangeDSAccess
    Event ID: 2069
    Computer: Computer_Name
    Description: Process Process.exe (PID=Pid_Id. Dsaccess could not find any global catalog servers in the enterprise. Promote one or more of your domain controllers to a global catalog to allow dsaccess to function properly.

  • When you try to obtain a list of global catalog servers in Microsoft Exchange 2000 Server or in Microsoft Exchange Server 2003, the following information may be logged in the application event log:


    Event Type: Error
    Event Source: MSExchangeDSAccess
    Event Category: None
    Event ID: 2075
    Date: Date
    Time: Time
    User: N/A
    Computer: Computer_Name
    Description: Process STORE.EXE (PID=2152). DsBind failed. DomainName, hr=0x8007054b, deltaT=31. The operation will be retried. You may be unable to connect to the Exchange server.

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Cause

These issues may occur if a domain controller in the Microsoft Windows domain has been removed. When a domain controller is removed from a Windows domain, all the symptoms that are described in the "Symptoms" section occur if the following conditions are true:
  • Microsoft Exchange had been using the domain controller that has been removed as its global catalog referral server. There is still a reference to the domain controller in Domain Name System (DNS). Specifically, there is a host record that still points to the domain controller that was removed.
  • The domain controller that has been removed was configured as an alternative DNS server in the properties of TCP/IP on all the domain controllers.
  • DSProxy detects a problem while obtaining the list of global catalog servers from DSAccess. DSProxy triggers a failure, and the clients cannot connect to the Exchange server.

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Resolution

To resolve these issues, use one or more of the follow methods.

Method 1: Update the DNS information

You must update the DNS information on your Exchange server by removing the host record that is pointing to the domain controller that was removed. To do this, follow these steps:
  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. At the command prompt, type the following commands, and then press ENTER after each command:
    ipconfig /flushdns
    ipconfig /registerdns
This procedure updates the DNS information. Exchange will then link with a domain controller that is online.

Method 2: Verify that the DNS server contains the record to the global catalog server

You must verify that the DNS server contains the record to the global catalog server. To do this, first follow these steps on the DNS server computer:
  1. Click Start, point to Programs, point to Administrative Tools, and then click DNS.
  2. Expand Forward Lookup Zones, expand domain name, and then expand the global catalog.
  3. In the right pane, locate the Host or the A record for the global catalog, and then note the IP address.
Next, follow these steps on the computer that is running Exchange Server:
  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. At the command prompt, type the following command, and then press ENTER:
    ipconfig /all
  3. Note the IP address that is listed for the DNS servers. Make sure that the IP address of the DNS server matches the IP address of the Host or the A record for the global catalog that you noted in the Forward Lookup Zones on the DNS server.
  4. If an external DNS server is listed, follow these steps to remove the external DNS server:
    1. Right-click My Network Places, and then click Properties.
    2. Right-click Local Area Connection, and then click Properties.
    3. Click Internet Protocol (TCP/IP), and then click Properties.
    4. In the Use the following DNS server addresses area, remove the IP address of the external DNS server.
    5. Click OK two times, and then close Network and Dial-up Connections.
  5. At the command prompt, type the following commands, and then press ENTER after each command:
    ipconfig /flushdns
    ipconfig /registerdns

Method 3: Configure the DNS server to locate its domain global catalog servers

Either a Standard Primary DNS zone or an Active Directory DNS zone must contain the _msdcs, the _sites, the _tcp, and the _udp domain records. To verify the DNS settings, follow these steps:
  1. On the DNS server, click Start, point to Programs, point to Administrative Tools, and then click DNS.
  2. Expand Your_Computer_Name, expand Forward Lookup Zones, and then expand Your_Domain_Name. The following four folders must appear under Your_Domain_Name:
    • _msdcs
    • _sites
    • _tcp
    • _udp
  3. If the folders are not listed, correct the DNS settings. To do this, follow these steps:
    1. Right-click the Your_Domain_Name, and then click Properties.
    2. Click the General tab, and then click Yes in the Allow Dynamics Updates list.
    3. On the DNS server, click Start, point to Programs, right-click My Network Places, and then click Properties.
    4. Right-click Local Area Connection, click Properties, click Internet Protocol (TCP/IP), and then click Properties.
    5. In the Internet Protocol (TCP/IP) Properties window, verify that the Use the following DNS Server addresses check box is selected and that a valid DNS IP address appears in the Preferred IP Address box.

      Note The IP Address must correspond to the DNS server IP address in the domain. You must use an IP address that does not change for the server. Do not use the IP address of your Internet service provider (ISP).
    6. Click Advanced, and then click the DNS tab.
    7. Verify that your domain name appears in the DNS suffix for this connection box, and make sure that the Register this connection�s addresses in DNS and the Use this connection�s DNS suffix in DNS registration check boxes are selected for this DNS.
    8. Click OK three times, and then close Network and Dial-up Connections.

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More information

For more information about event ID 9074, click the following article number to view the article in the Microsoft Knowledge Base:
279742 Exchange 2000 Server reports MSExchangeSA 9074
For more information about managing and getting information about Microsoft Windows based DNS Servers, visit the following Web site:

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Keywords: KB895858, kbprb, kbtshoot, kbdirectory

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Article Info
Article ID : 895858
Revision : 6
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 321