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Public folders may not be visible to Exchange users after you upgrade from Exchange Server version 5.5 to Exchange 2000 Server or to Exchange Server 2003


View products that this article applies to.

Symptoms

After you upgrade Microsoft Exchange Server version 5.5 to Microsoft Exchange 2000 Server or to Microsoft Exchange Server 2003, some folders that are in public folders may not be visible to Microsoft Exchange users.

This issue may occur even if the following conditions are true:
  • All the folders that are in public folders are visible when Exchange users use Exchange System Manager.
  • All the public folders are replicated to other servers.
  • The public folders are assigned the default permissions
Additionally, when you view the Application log in Event Viewer, you may see an event that is similar to the following for every folder that the Exchange users cannot view:


Event Type: Warning
Event Source: MSExchangeIS Public Store
Event Category: General
Event ID: 9551
Description: An error occurred while upgrading the ACL on folder [Public Folders]/PF located on database "First Storage Group\Public Folder Store (Server_name)". The Information Store was unable to convert the security for /O=Org/OU=Site/CN=RECIPIENTS/CN=DL into a Windows 2000 Security Identifier. It is possible that this is caused by latency in the Active Directory Service, if so, wait until the user record is replicated to the Active Directory and attempt to access the folder (it will be upgraded in place). If the specified object does NOT get replicated to the Active Directory, use the Microsoft Exchange System Manager or the Exchange Client to update the ACL on the folder manually. The access rights in the ACE for this DN were 0x41b.

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Cause

This issue may occur if the account of the creator and owner of the public folders that cannot be viewed is not a valid account. If the account of the creator and owner was deleted before Exchange Server 5.5 is upgraded to Exchange 2000 Server or to Exchange Server 2003, that account is not in the Active Directory directory service. Therefore, the public folders that cannot be viewed do not have a creator and owner. Public folders that do not have a creator and owner cannot be viewed by the Exchange users.

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Resolution

To resolve this issue, use the Administrator account to take ownership of the public folders that cannot be viewed by the Exchange users. To do this, follow these steps:
  1. Log on to the computer that is running an Exchange Administrator account.
  2. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
  3. Expand the Folders container, and then expand the Public Folders container.
  4. Right-click the public folder that you want to take ownership of, and then click Properties.
  5. Click the Permissions tab, and then click Client permissions.
  6. Note any invalid accounts and the account permissions that are in the Client Permissions list. For example, note any accounts that do not exist in Active Directory.
  7. If an invalid account is listed, click the name of the invalid account, and then click Remove.

    Note To remove more than one invalid account, press and hold the CTRL key, click the invalid user names, release the CTRL key, and then click Remove.
  8. To add a valid user account, click Add, click the user name that you want to add, and then click Add.
  9. When you have added all the user accounts that you want, click OK.
  10. Click the user name that you want to make the owner of the public folder, and then click Owner in the Roles list.
  11. Click OK two times.

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More information

For more information about how to prevent this issue, click the following article number to view the article in the Microsoft Knowledge Base:
328287 How to prevent permissions problems when you migrate public folders to Exchange 2000 Server or Exchange Server 2003

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Keywords: KB895855, kbprb, kbtshoot, kbsetup

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Article Info
Article ID : 895855
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 324