Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: SCS control codes for PPM may not be correctly read in Host Integration Server 2000 and in Host Integration Server 2004


View products that this article applies to.

Symptoms

SNA Character String (SCS) control codes for page presentation media (PPM) may not be correctly read in Microsoft Host Integration Server 2000 and in Host Integration Server 2004. After you upgrade from Microsoft SNA Server 4.0 to Microsoft Host Integration Server 2000 or to Host Integration Server 2004, you may receive blank pages when you try to print a page. Additionally, an internal trace may show the following errors:
  • Bad DataStream
  • Unrecognized SCS sequence

↑ Back to the top


Cause

This problem occurs when you receive LU1 print data that contains PPM that has a valid but meaningless length value. For example, valid lengths values are 2 to 12, decimal. However, only the following length values have a meaning:
  • 2
  • 5
  • 6
  • 10
Therefore, if the length value does not have a meaning, the data is rejected and is not printed.

↑ Back to the top


Resolution

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   07-Dec-2004  19:56  5.0.0.1012         20,752  Msg5250.dll      
   07-Dec-2004  19:56  5.0.0.1012        250,128  Ppd3270.dll      
   07-Dec-2004  19:56  5.0.0.1012        139,536  Ppd5250.dll      
   07-Dec-2004  19:56  5.0.0.1012         49,424  Prmngext.dll     
   07-Dec-2004  19:55  5.0.0.1012        209,168  Snacfg.dll       
   07-Dec-2004  19:56  5.0.0.1012         24,848  Snaxlt.dll       
   07-Dec-2004  19:56  5.0.0.1012        282,896  Winvprt.dll      
   07-Dec-2004  19:56  5.0.0.1012         57,616  Pdfcomp.exe      
   07-Dec-2004  19:56  5.0.0.1012         94,480  Snaprint.exe     

				
Note Because of file dependencies, the most recent hotfix that contains the previous files may also contain additional files.

Host Integration Server 2004

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   08-Dec-2004  04:24  6.0.1917.0         29,184  Msg5250.dll      
   08-Dec-2004  04:24  6.0.1917.0         39,424  Pdfcomp.exe      
   08-Dec-2004  04:24  6.0.1917.0        184,320  Ppd3270.dll      
   08-Dec-2004  04:24  6.0.1917.0         93,184  Ppd5250.dll      
   08-Dec-2004  04:24  6.0.1917.0         33,280  Prmngext.dll     
   08-Dec-2004  04:24  6.0.1917.0        167,936  Snacfg.dll       
   08-Dec-2004  04:24  6.0.1917.0         61,440  Snaprint.exe     
   08-Dec-2004  04:24  6.0.1917.0         12,288  Snaxlt.dll       
   08-Dec-2004  04:24  6.0.1917.0        195,072  Winvprt.dll      

				
Note Because of file dependencies, the most recent hotfix that contains the previous files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

↑ Back to the top


Keywords: KB890641, kbbug, kbfix, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 890641
Revision : 8
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 339