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FIX: Host print sessions may stop responding (hang) when the Request Definite Response option is enabled in Host Integration Server


View products that this article applies to.

Symptoms

In Microsoft Host Integration Server, host print sessions that have the Request Definite Response option enabled may stop responding (hang). After this problem occurs, you cannot send any new host print jobs to the host print session.

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Cause

This problem occurs because the print server does not send a response to the host system when a print job is completed if the time that is between print jobs is more than the timeout that is configured in the After Job Ends, Delay Closing Printer option in the print session. Because the host system is waiting for a response that indicates that the previous job has completed printing, additional print jobs cannot be sent to the print session. This behavior causes the print session to stop responding.

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Resolution

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Sep-2004  16:34  5.0.0.1002   20,752  Msg5250.dll
   29-Sep-2004  16:34  5.0.0.1002  250,128  Ppd3270.dll
   29-Sep-2004  16:34  5.0.0.1002  139,536  Ppd5250.dll
   29-Sep-2004  16:34  5.0.0.1002   49,424  Prmngext.dll
   29-Sep-2004  16:34  5.0.0.1002  209,168  Snacfg.dll
   29-Sep-2004  16:34  5.0.0.1002   24,848  Snaxlt.dll
   29-Sep-2004  16:34  5.0.0.1002  282,896  Winvprt.dll
   29-Sep-2004  16:34  5.0.0.1002   57,616  Pdfcomp.exe
   29-Sep-2004  16:34  5.0.0.1002   94,480  Snaprint.exe

				
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

Host Integration Server 2004

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Sep-2004  17:33  6.0.1905.0   29,184  Msg5250.dll
   29-Sep-2004  17:33  6.0.1905.0   39,424  Pdfcomp.exe
   29-Sep-2004  17:33  6.0.1905.0  183,808  Ppd3270.dll
   29-Sep-2004  17:33  6.0.1905.0   93,184  Ppd5250.dll
   29-Sep-2004  17:33  6.0.1905.0   33,280  Prmngext.dll
   29-Sep-2004  17:33  6.0.1905.0  167,936  Snacfg.dll
   29-Sep-2004  17:33  6.0.1905.0   61,440  Snaprint.exe
   29-Sep-2004  17:33  6.0.1905.0   12,288  Snaxlt.dll
   29-Sep-2004  17:33  6.0.1905.0  194,560  Winvprt.dll
				

Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

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Workaround

To work around this problem, disable one or both of the following configuration options in the print session properties:
  • Request Definite Response
  • After Job Ends, Delay Closing Printer

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

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More information

In SNA Server 4.0 and earlier versions, the host print service (Snaprint.exe) opens all defined printers that are used by the configured host print sessions when the service starts. The After Job Ends, Delay Closing Printer option was added in Host Integration Server 2000 to optimize performance and system resources. If the printer is always available, system resources such as printer handles are consumed. However, if the printer is constantly opened and closed with each print job that is sent, performance suffers. By setting the After Job Ends, Delay Closing Printer timeout option, the printer will remain available for print jobs that are sent close together to improve performance, and the printer will close during non-busy times to free resources.

By default, the After Job Ends, Delay Closing Printer option is enabled and the timeout is set to 10 seconds on Host Integration Server 2000 and Host Integration Server 2004.

The problem that is described in the "Symptoms" section occurs when the Request Definite Response and After Job Ends, Delay Closing Printer options are both enabled on a host print session. If multiple host print jobs are sent to the host print session and the delay between each print job is less than the timeout that is specified in the After Job Ends, Delay Closing Printer timeout option, all the print jobs are printed. Additionally, the host print service sends a response to the host system to indicate that each job printed successfully. The Request Definite Response option provides this functionality.

If multiple host print jobs are sent to the host print session and the delay between one or more of the print jobs is more than the After Job Ends, Delay Closing Printer timeout option, all the print jobs are successfully printed. However, the host print service does not send a response to the host system for the print job that was sent after the After Job Ends, Delay Closing Printer timeout expired. This behavior causes the print session to stop responding because the host system will not send any additional print jobs to the print session while it is waiting for the response to the previous print job.

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Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbhostintegserv2000presp2fix, kbfix, kbbug, KB886666

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Article Info
Article ID : 886666
Revision : 8
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 416