Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: SNA Manager does not display the correct remote APPC LU session status if you update the SNA Manager MMC snap-in after APPC sessions are re-established in Host Integration Server


View products that this article applies to.

Symptoms

In Microsoft Host Integration Server 2000 and Host Integration Server 2004, SNA Manager does not display the correct Advanced Program-to-Program Communications (APPC) session status when you view a remote APPC logical unit (LU). This problem occurs if the SNA Manager MMC snap-in is updated after APPC sessions are reestablished.

When the problem occurs, it seems that no active sessions exist over the remote APPC LU that is being viewed in SNA Manager. If you change the focus in SNA Manager to view the local APPC LU that is partnered with the remote APPC LU, SNA Manager shows that active sessions exist over the remote APPC LU.

↑ Back to the top


Cause

This problem occurs because the Host Integration Server management components do not correctly update the remote APPC LU status after the SNA Manager MMC snap-in is update and the update occurs after APPC sessions are reestablished.

↑ Back to the top


Resolution

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   21-Oct-2004  23:16  5.0.0.1006  114,960  Mngbase.dll      
   21-Oct-2004  23:16  5.0.0.1006  114,960  Mngsna.dll       
   21-Oct-2004  23:16  5.0.0.1006  102,672  Mngagent.exe     
   21-Oct-2004  23:16  5.0.0.1006  102,672  Mngcli.exe       
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

Host Integration Server 2004

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size    File name
   ----------------------------------------------------
   22-Oct-2004  22:00  6.0.1908.0  82,432  Mngagent.exe     
   22-Oct-2004  22:00  6.0.1908.0  88,064  Mngbase.dll      
   22-Oct-2004  22:00  6.0.1908.0  81,920  Mngcli.exe       
   22-Oct-2004  22:00  6.0.1908.0  95,744  Mngsna.dll
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

↑ Back to the top


Workaround

To work around this problem, stop and then restart the SNA MngAgent service. When you do this, SNA Manager will display the correct status for APPC sessions when you view a remote APPC LU.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

↑ Back to the top


More information

Steps to reproduce the problem

  1. Open the SNA Manager MMC snap-in.
  2. Expand the Host Integration Server subdomain tree, and choose a configured remote APPC LU.
  3. Start an APPC application that will establish an APPC session by using the remote APPC LU that you chose in step 2. Do this so the correct status appears for an active APPC session.
  4. Stop the SNA Server service that the chosen remote APPC LU is using to communicate with the IBM host system.
  5. After the SNA Server service has successfully stopped, restart the SNA Server service.
  6. Start the APPC application again to establish an APPC session by using the same remote APPC LU.
  7. Press F5 to update the SNA Manager MMC snap-in.

    The active APPC sessions that previously appeared when you viewed the remote APPC LU no longer appear even though they are still active.

    If you change the focus in SNA Manager to the local APPC LU that the APPC sessions are also using, the correct status of the APPC sessions will appear.

↑ Back to the top


Keywords: KB885429, kbbug, kbfix, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 885429
Revision : 8
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 403