Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Deleting a Workstation record may cause the removal of LU assignments from other Workstation records in Host Integration Server


View products that this article applies to.

Symptoms

LUs or pools that are assigned to a Workstation record that is deleted in a Microsoft Host Integration Server configuration may also be removed from other Workstation records. This behavior only occurs when the same LUs or pools are assigned to multiple Workstation records in a Host Integration Server configuration.

↑ Back to the top


Cause

When you delete a Workstation record that has LU or pool assignments, the links to the LU or pool record must be removed from the Workstation record. The Host Integration Server configuration DLL (Snacfg.dll) deletes the LU and pool records without verifying the associated Workstation record. Therefore, the LU or pool records will be removed from the deleted Workstation record and from any other Workstation records that they are assigned to.

↑ Back to the top


Resolution

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   ---------------------------------------------------
   10-Sep-2004  17:04  5.0.0.1001  209,168  Snacfg.dll
				

Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

Host Integration Server 2004

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   ---------------------------------------------------
   16-Sep-2004  17:33  6.0.1904.0  167,936  Snacfg.dll
				

Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

↑ Back to the top


Workaround

You can use one of the following methods to prevent LU or pool records from being deleted from other Workstation records:
  • Delete the LUs or pools from the Workstation record before you delete the Workstation record. SNA Manager will not let LUs be deleted from the Workstation record if the LUs are being used.
  • Use the SNA command-line configuration utility (Snacfg.exe) to remove the LUs or pools from the Workstation record before you delete the Workstation definition. Snacfg.exe will let you remove LUs that are being used from a Workstation record. Use the following format to remove LUs or pools from a Workstation record by using Snacfg.exe:
    snacfg workstation workstation ID /remove: LU/pool name

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

↑ Back to the top


More information

The following sample configuration can cause the problem that is described in the "Symptoms" section:
  1. Create two Workstation records in the Host Integration Server configuration by using SNA Manager. For example, name the records Workstation 1 and Workstation2.
  2. Assign the same LUs or pools to each Workstation definition. For example, LU1, LU2, and LU3.
  3. Save the Host Integration Server configuration.
  4. Delete the first Workstation record that you created. For example, delete Workstation1.
  5. Save the configuration.
  6. Refresh the configuration or restart SNA Manager.

    Notice that the LUs or pools have also been removed from the second Workstation record. For example, this record may be Workstation2.
The problem does not occur if you delete the second or any subsequent Workstation records. This problem only occurs when the first Workstation record to which the duplicate LU or pool records were assigned is deleted from the Host Integration Server configuration.

↑ Back to the top


Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbhostintegserv2000presp2fix, kbfix, kbbug, KB884563

↑ Back to the top

Article Info
Article ID : 884563
Revision : 7
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 442