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FIX: APPC and Common Programming Interface for Communications (CPI-C) applications may stop responding if the SNA Server service becomes unavailable


View products that this article applies to.

Symptoms

APPC and Common Programming Interface for Communications (CPI-C) applications may stop responding (hangs) if the SNA Server service (Snaservr.exe) that the application is communicating through becomes unavailable.

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Cause

The underlying Microsoft Host Integration Server dynamic address module (DMOD) client/server interface will try to establish a connection to another SNA Server service if it loses its connection to the SNA Server service that it was previously communicating with. If the connection to another SNA Server service fails and the DMOD retries the connection more than 32 times, an access violation occurs in the APPC library (Wappc32.dll). Any subsequent APPC or CPI-C calls that are issued by the application do not complete after the access violation occurs. Therefore, the APPC or CPI-C application stops responding.

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Resolution

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version    Size c   File name
   ---------------------------------------------------
   20-Aug-2004  16:38  5.0.0.996  229,648  Wappc32.dll

Host Integration Server 2004

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   ----------------------------------------------------
   20-Aug-2004  17:36  6.0.1903.0  163,328  Wappc32.dll

				

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

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Keywords: KB884550, kbbug, kbfix, kbhostintegserv2000presp2fix, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 884550
Revision : 7
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 447