Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Host Integration Server Host Print service may not process the end of LU1 print jobs correctly when the print sessions use a print filter DLL


View products that this article applies to.

Symptoms

The Microsoft Host Integration Server 2004 Host Print service may not process the end of LU1 print jobs correctly when the print sessions are configured to use a print filter DLL. You may experience different symptoms depending on the print job and the print filter DLL that is being used. For example, this problem may cause the affected print session to be terminated abnormally, or you may not notice any visible symptoms at all.

↑ Back to the top


Cause

If multiple LU1 print jobs are received, the SNA Print service calls the print filter DLL after the end of the first job before the service reopens the print filter at the start of the second job. This behavior only occurs if you choose the Printer language is Hewlett Packard (HP) PCL option.

↑ Back to the top


Resolution

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date          Time   Version    Size     File name
   ----------------------------------------------------
   05-Aug-2004  18:09  5.0.0.994   20,752  Msg5250.dll
   05-Aug-2004  18:09  5.0.0.994  250,128  Ppd3270.dll
   05-Aug-2004  18:09  5.0.0.994  139,536  Ppd5250.dll
   05-Aug-2004  18:09  5.0.0.994   49,424  Prmngext.dll
   05-Aug-2004  18:08  5.0.0.994  209,168  Snacfg.dll
   05-Aug-2004  18:09  5.0.0.994   24,848  Snaxlt.dll
   05-Aug-2004  18:09  5.0.0.994  282,896  Winvprt.dll
   05-Aug-2004  18:09  5.0.0.994   57,616  Pdfcomp.exe
   05-Aug-2004  18:09  5.0.0.994   94,480  Snaprint.exe
				

Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

Host Integration Server 2004

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   20-Aug-2004  17:37  6.0.1903.0   29,184  Msg5250.dll
   20-Aug-2004  17:37  6.0.1903.0   39,424  Pdfcomp.exe
   20-Aug-2004  17:37  6.0.1903.0  183,808  Ppd3270.dll
   20-Aug-2004  17:37  6.0.1903.0   93,184  Ppd5250.dll
   20-Aug-2004  17:37  6.0.1903.0   33,280  Prmngext.dll
   20-Aug-2004  17:36  6.0.1903.0  167,936  Snacfg.dll
   20-Aug-2004  17:37  6.0.1903.0   61,440  Snaprint.exe
   20-Aug-2004  17:37  6.0.1903.0   12,288  Snaxlt.dll
   20-Aug-2004  17:37  6.0.1903.0  194,560  Winvprt.dll


				

Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

↑ Back to the top


Keywords: KB884023, kbbug, kbfix, kbhostintegserv2000presp2fix, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 884023
Revision : 8
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 404