Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: You receive an "Event 60" in the application event log after you restart a server that is running Host Integration Server 2000 Service Pack 1 in a multiple-server Host Integration Server subdomain


View products that this article applies to.

Symptoms

After you restart a server that is running Microsoft Host Integration Server 2000 Service Pack (SP1) in a multiple-server Host Integration Server subdomain, the server may stop forwarding Function Management Header-5 (FMH-5) Attach messages to a Host Integration Server 2000 client computer that is running a certain kind of invokable transaction program (TP). This TP is either an Advanced Program-to-Program Communication (APPC) TP or a Common Programming Interface for Communications (CPI-C) TP.

This problem may also occur if you restart the SnaBase service on the server that is running Host Integration Server 2000 SP1.

Additionally, when the FMH-5 Attach message cannot be routed to the invokable TP, the following event is logged in the application event log on the Host Integration Server 2000 server:
Event ID: 60
Source: SNA Server
Description: Failed to invoke APPC TP TPName, sense data = 084C0000
Note You experience these symptoms only in a multiple-server Host Integration Server 2000 subdomain that contains servers that are running Host Integration Server 2000 SP1 that have the following update applied:
829980� An invokable transaction program (TP) is not available after you restart Host Integration Server 2000

↑ Back to the top


Cause

The update that is described in Microsoft Knowledge Base article 829980 incorrectly changed an initialization sequence. The change in the initialization sequence causes the registration of invokable TPs to fail after you restart a Host Integration Server 2000 SP1 server that has the update applied.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152� How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version    Size     File name
   ---------------------------------------------------
   10-Aug-2004  22:51  5.0.0.995  286,992  Snabase.exe
				
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

↑ Back to the top


More information

The update that is described in this article supersedes the update that is described in Knowledge Base article 829980.

↑ Back to the top


Keywords: KB875546, kbhotfixserver, kbqfe, kbfix, kbbug, kbtshoot

↑ Back to the top

Article Info
Article ID : 875546
Revision : 3
Created on : 6/5/2006
Published on : 6/5/2006
Exists online : False
Views : 387