Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

SQL Server Error 10040 or 10004 "Unable to connect: SQL Server is unavailable or does not exist" logging on to Solomon


View products that this article applies to.

TechKnowledge Content



SUMMARY


SQL Server Error 10040 or 10004 (Severity 9) - "Unable to connect: SQL Server is unavailable or does not exist. Specified SQL Server not found" occurs when you try to log on to Dynamics SL.

CAUSE


This error occurs because:


1. The Network Library settings for SQL Server need to be changed.


-or-


2. An invalid Server Alias exists in the Client Network Utility.


RESOLUTION


Cause 1:
The Network Library settings for SQL Server need to be changed.


Follow these steps to change the order in which protocols load in the Microsoft SQL Server Client Network Utility:


1. Click Start, point to Programs, point to Microsoft SQL Server, and then click Client Network Utility.


2. Under the General tab, verify that both Named Pipes and TCP/IP are enabled.


3. If they are not, enable both and test the issue again.


4. If they are both enabled, change the order in which they load by highlighting the top item and pressing the down arrow below.


5. Click OK.


Notes

1. There is no set recommendation on which protocol should be loading first. Depending on network configurations, one protocol may work better than the other.


2. The way in which the network is configured for obtaining IP Addresses may affect performance and/or connectivity with Solomon. Typically, Named Pipes should load first with Static IP, and TCP/IP should load first with DHCP; however, this is not always the case.


3. Troubleshooting these types of issues is usually a matter of trying both to determine which provides better performance.


Cause 2: An invalid Server Alias exists in the Client Network Utility.


To remove or correct the invalid Server Alias, follow these steps:


1. Click Start, point to Programs, point to Microsoft SQL Server, and then click Client Network Utility.


2. Click the Alias tab.


3. If an invalid Server Alias exists, either delete or correct it.


- To delete the Alias, click the Alias, and then click Remove.


- To correct the Alias, click the Alias, click Edit, make the appropriate changes, and then click OK.


4. Click OK to exit the SQL Server Client Network Utility.

This article was TechKnowledge Document ID:114385

↑ Back to the top


Keywords: kbretire, kbmbsenvironment, kbmbspartner, kbmbsmigrate, kb, kbarchive

↑ Back to the top

Article Info
Article ID : 844306
Revision : 1
Created on : 1/7/2017
Published on : 7/25/2012
Exists online : False
Views : 435