Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The host header is not updated to reflect the new port number in Internet Explorer when you redirect HTTP requests that contain a port number


View products that this article applies to.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

When you redirect HTTP requests that contain a port number, you notice that the redirected host header is not updated to reflect the new port number in Microsoft Internet Explorer 6.

↑ Back to the top


Cause

This problem occurs because Internet Explorer 6 is not RFC-compliant for the host header.

↑ Back to the top


Resolution

To resolve this problem, you must install the hotfix that is described in this article. Then you must configure the registry.

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Internet Explorer 6 for Windows XP

   Date         Time   Version        Size     File name
   --------------------------------------------------------
   12-Aug-2004  22:49  6.0.2800.1463  572,416  Wininet.dll

Internet Explorer 6 for Windows XP Service Pack 2

   Date         Time   Version        Size     File name
   --------------------------------------------------------
   06-Mar-2005  00:33  6.0.2900.2625  657,920  Wininet.dll
   25-Feb-2005  03:53  6.1.22.4       371,936  Updspapi.dll

Internet Explorer 6 for Windows Server 2003

   Date         Time   Version       Size     File name
   --------------------------------------------------------
   05-Mar-2005  03:48  6.0.3790.283  628,224  Wininet.dll

Internet Explorer 6 for Windows Server 2003 with Service Pack 1, Itanium-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wininet.dll6.0.3790.26301,700,35201-Feb-200609:25IA-64SP1SP1QFE
Wwininet.dll6.0.3790.2630664,06401-Feb-200609:25x86SP1WOW

Internet Explorer 6 for Windows Server 2003 with Service Pack 1, x64-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wininet.dll6.0.3790.26301,187,84001-Feb-200609:25x64SP1SP1QFE
Wwininet.dll6.0.3790.2630664,06401-Feb-200609:25x86SP1WOW

Internet Explorer 6 for Windows Server 2003 with Service Pack 1, x86-based versions

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wininet.dll6.0.3790.2630664,06401-Feb-200608:13x86


Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To configure the option for the computer, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following subkey in the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type UPDATE_HOST_PORT_ON_REDIRECT_KB843518 for the name of the subkey, and then press ENTER.
  5. Click the UPDATE_HOST_PORT_ON_REDIRECT_KB843518 subkey, point to New on the Edit menu, and then click DWORD Value.
  6. Type iexplore.exe for the name of the DWORD, and then press ENTER.
  7. Right-click iexplore.exe, and then click Modify.
  8. In the Value data box, type 0x1 , and then click OK.
  9. Locate and then click the following subkey in the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl
  10. On the Edit menu, point to New, and then click Key.
  11. Type UPDATE_HOST_PORT_ON_REDIRECT_KB843518 for the name of the subkey, and then press ENTER.
  12. Click the UPDATE_HOST_PORT_ON_REDIRECT_KB843518 subkey, and then on the Edit menu, point to New, and then click DWORD Value.
  13. Type iexplore.exe for the name of the DWORD, and then press ENTER.
  14. Right-click iexplore.exe, and then click Modify.
  15. In the Value data box, type 0x1, and then click OK.
  16. Quit Registry Editor.
To configure the option for the user, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following subkey in the registry:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type UPDATE_HOST_PORT_ON_REDIRECT_KB843518 for the name of the subkey, and then press ENTER.
  5. Click the UPDATE_HOST_PORT_ON_REDIRECT_KB843518 subkey, point to New on the Edit menu, and then click DWORD Value.
  6. On the Edit menu, point to New, and then click DWORD Value.
  7. Type iexplore.exe for the name of the DWORD, and then press ENTER.
  8. Right-click iexplore.exe, and then click Modify.
  9. In the Value data box, type 0x1, and then click OK.
  10. Locate and then click the following subkey in the registry:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Main\FeatureControl
  11. On the Edit menu, point to New, and then click Key.
  12. Type UPDATE_HOST_PORT_ON_REDIRECT_KB843518 for the name of the subkey, and then press ENTER.
  13. Click the UPDATE_HOST_PORT_ON_REDIRECT_KB843518 subkey, point to New on the Edit menu, and then click DWORD Value.
  14. Type iexplore.exe for the name of the DWORD, and then press ENTER.
  15. Right-click iexplore.exe, and then click Modify.
  16. In the Value data box, type 0x1, and then click OK.
  17. Quit Registry Editor.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbwinserv2003sp2fix, kbwinxppresp3fix, kbqfe, kbfix, kbbug, kbhotfixserver, KB843518

↑ Back to the top

Article Info
Article ID : 843518
Revision : 7
Created on : 8/29/2007
Published on : 8/29/2007
Exists online : False
Views : 379