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SMTP proxy addresses that contain Nordic characters are not displayed correctly in Exchange Server 2003 and in Exchange 2000 Server


View products that this article applies to.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

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Symptoms

When you add a new mailbox to a computer that is running Microsoft Exchange Server 2003 or Microsoft Exchange Server 2000, if the name includes an extended Nordic character such as an "�," an "�," or an "�," the character is converted to "ae" or to "oe" in the X.400 and SMTP proxy addresses. This character conversion also occurs when common names are generated. This character conversion is correct for German names, but it is incorrect for Scandinavian names. To make sense for Nordic characters, these extended characters must be converted to an "a" character and to an "o" character.

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Cause

This behavior occurs because when you select a system locale on the Exchange Server properties in Exchange System Manager (ESM) to reflect the way SMTP proxy addresses are generated, Exchange Server always returns the default system locale that is selected for the local system account. By default, the System Attendant service runs under the local system account. Therefore, it is not important which system locale you select in ESM because the system locale for the local system account is always returned.

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Resolution

Exchange 2000 Server

To resolve this issue, you must change the system locale to the preferred language, set the default language for the Exchange Server, and add a registry entry to support international sorting. To do this, follow these steps.

Note You can use this procedure to resolve the same issue for the Turkish language. You do not have to make any changes to the procedure to do this. For example, you do not have to replace "Turkish" for "Danish" because they share the same character sets.
  1. Change the system locale to the preferred language. To do this, follow these steps on the Exchange Server 2003 server that is hosting the RUS::
    1. Click Start, point to Settings, and then click Control Panel.
    2. Double-click Regional Options.
    3. In the Language settings for the system area, click Set default.
    4. Make sure that the correct language setting is selected, and then click OK. For example, click Danish, and then click OK.
    5. Click OK.
  2. Add the languages that will be supported on the site to the Exchange Server, and then set the default language for the server. To do this, follow these steps on the Exchange Server 2003 server that is hosting the RUS.

    Note The default language should be set to the primary language that is supported on the site.
    1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
    2. Expand Administrative Groups, expand the first administrative group that was created in your organization, and then click Servers.
    3. Right-click your server name, and then click Properties.
    4. Click Add on the Locales tab.
    5. In the Locales list, click to select the client language to be supported, and then click OK.
    6. Click OK.
  3. Add a registry entry to support international sorting. To do this, follow these steps on the Global Catalog servers that are used by the RUS. This step allows the GC to provide support for the Danish language.

    Note Change these registry settings on the global catalog server for the domain. If there is more than one domain controller in your domain, make sure that only one of the domain controllers is configured as a global catalog server.

    Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and click the following registry subkey:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ntds\Language
    3. On the Edit menu, point to New, click DWORD Value, and then type Language 00000196.
    4. Double-click Language 00000196, set the hexadecimal value to 00000196, and then click OK.

      Note By default, the only Language registry entry on a computer that is running the English version of Windows 2000 Server is the following:

      Value Name: Language 00000409
      Value data: 00000409
    5. Quit Registry Editor.
    6. Restart the computer.

Exchange Server 2003

  1. Perform the following steps on the Global Catalog server(s) used by the RUS. This step allows the GC to provide support for the Danish language.
    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and click the following registry subkey:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ntds\Language
    3. On the Edit menu, point to New, click DWORD Value, and then type Language 00000196.
    4. Double-click Language 00000196, set the hexadecimal value to 00000196, and then click OK.

      Note By default, the only Language registry entry on a computer that is running the English version of Windows 2000 Server is the following:
      Value Name: Language 00000409
      Value data: 00000409
    5. Quit Registry Editor.
    6. Restart the computer.
  2. Perform the following steps on the Exchange 2003 Server hosting the RUS:
    1. Click Start, and then click Control Panel.
    2. In Control Panel, click Regional and Language Options.
    3. On the Advanced tab under Language for non-Unicode programs, select Danish, and then click OK. If prompted to skip copying files, choose Yes.
    4. When prompted to restart the server, choose No.
    5. In ESM, go to the Locales tab of the server's Properties dialog, click Add, select Danish, and then click OK. At the warning prompt to install code pages and restart Exchange Services, click OK.
    6. Restart the server.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The system locales that are supported by Exchange 2000 are determined when the server is installed. For more information about how to modify the locales that are supported by Exchange 2000, see "Set Locales" in Exchange 2000 Help.

For additional information about multiple language support in Exchange 2000, click the following article number to view the article in the Microsoft Knowledge Base:
325622� Plan and configure multiple language support in Exchange 2000

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Keywords: KB841578, kbprb, kbtransport

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Article Info
Article ID : 841578
Revision : 2
Created on : 5/29/2008
Published on : 5/29/2008
Exists online : False
Views : 331