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The Microsoft Exchange Routing Engine service does not start and logs events 116, 953, or 7023


View products that this article applies to.

Symptoms

In Microsoft Exchange Server 2003 and in Microsoft Exchange 2000 Server, the Microsoft Exchange Routing Engine service (RESVC) may not start. Additionally, the following errors may be logged in the application event log:

Event 1

Event Type: Error
Event Source: RESVC
Event Category: None
Event ID: 116
Computer: Computer Name
Description: The service metabase path '/LM/RESVC/' could not be opened. The data is the error code.
Data: 0000: 03 00 00 00 ....

Event 2

Event Type: Warning
Event Source: MSExchangeTransport
Event Category: Routing Engine/Service
Event ID: 953
Computer: Computer Name
Description: Following client routing node failed to connect to its resvc C:\WINDOWS\system32\inetsrv\inetinfo.exe


Additionally, the following error may be logged in the system event log:

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7023
Computer: Computer Name
Description: The Microsoft Exchange Routing Engine service terminated with the following error: The system cannot find the path specified.

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Cause

This issue may occur if the Microsoft Internet Information Services (IIS) metabase entry for the Microsoft Exchange Routing Engine service is removed or becomes corrupted. The routing engine component of Exchange runs under IIS and uses information that is contained in the IIS metabase. Typically, this issue occurs when IIS is removed from and reinstalled on a computer that is running Exchange 2003 or Exchange 2000. Additionally, this issue may occur when IIS stops responding or when the Exchange computer is turned off before the IIS shutdown is complete.

To confirm that this is the issue, follow these steps on the Exchange computer:
  1. Click Start, click Run, type cmd, and then click OK.
  2. Type cd\Inetpub\AdminScripts, and then press ENTER.
  3. Type cscript adsutil.vbs ENUM_ALL resvc, and then press ENTER.

    If you are experiencing this issue, you receive the following error message:
    Path not found
    ErrNumber: -2147024893 (0x80070003)
    Error Trying To ENUM the Object (GetObject Failed): resvc

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Resolution

To resolve this issue, use one of the following methods.

Method 1

If you have a recent backup of the IIS metabase from some time after you installed Exchange, restore the metabase from the backup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
302573 How to back up and restore IIS

Method 2

If no backup of the metabase exists, you can run the Exchange Setup program with the /reinstall switch. This will cause the Exchange Setup program to copy all the Exchange Server files and to replace missing entries in the metabase. You must also reapply any service packs and hotfixes.

If you have not recently removed IIS, it may be a good idea to try to determine the cause of the metabase corruption. If other IIS services are affected and will not start, you may have to remove and reinstall IIS before you complete the reinstallation of Exchange. Possible causes of metabase corruption include write caching, virus scanning, or editing of the metabase.bin file in an unsupported manner. A power failure or other type of system problem may also be the root cause.

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Keywords: KB841576, kberrmsg, kbprb

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Article Info
Article ID : 841576
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 367