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FIX: AK403 and AK501 validation errors occur when you generate 997 receipts in BizTalk Server 2002


View products that this article applies to.

Symptoms

When you use Microsoft BizTalk Server 2002 to generate X12 997 receipts, you may receive one or more of the following error messages:

Message 1
An error occurred in BizTalk Server.

Details:
------------------------------
[0x015e] The XML document has failed validation for the following reason:
Required attribute 'AK403' is missing.

[0x0140] The following channel configuration setting is not valid: "TPM Test Organization_TPM Test Organization_003_tpm-R"

[0x013f] The server could not finish processing the document.

[0x1730] Suspended Queue ID: "{4172C95B-E0C9-4062-A1AF-F6F15CFC3450}"

[0x013f] The server could not finish processing the document.
Message 2
An error occurred in BizTalk Server.

Details:
------------------------------
[0x015e] The XML document has failed validation for the following reason:
Required attribute 'AK501' is missing.

[0x0140] The following channel configuration setting is not valid: "TPM Test Organization_TPM Test Organization_003_tpm-R"

[0x013f] The server could not finish processing the document.

[0x1730] Suspended Queue ID: "{4F922BB1-78A1-48E1-86D0-C1B3F21E9A73}"

[0x013f] The server could not finish processing the document.

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Cause

This problem occurs because an error exists in the CanonicalReceiptTo4010-997.xml map for BizTalk Server 2002.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size    File name
   ----------------------------------------------------------
   17-Mar-2004  20:38  85,328  Canonicalreceiptto4010-997.xml
Note Because of file dependencies, the most recent hotfix that contains this file may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

For additional information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
Note After you apply this hotfix, you may need to refresh your existing receipt channels. To update all existing BizTalk Server objects, run the Refresh Messaging Manager Software Development Kit (SDK) sample. This sample is located in the following folder in a default installation of BizTalk Server 2002:
C:\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Refresh Messaging Manager\BTM_Refresh.exe

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Keywords: KB838835, kbbug, kbfix, kberrmsg, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 838835
Revision : 6
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 390