Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive a "Setup cannot update the file" error message when you install Office XP SP3


View products that this article applies to.

Symptoms

You try to install Microsoft Office XP Service Pack 3 (SP3) on one of the following computers:
  • A computer that is running Microsoft Windows Server 2003 that is also running Microsoft Internet Information Services (IIS) and Microsoft FrontPage Server Extensions 2002. .
  • A computer that is running Microsoft Windows 2000 Server that is also running Microsoft Internet Information Services (IIS) and Microsoft FrontPage Server Extensions 2002.
When you do this, you may receive the following error messages:
  • Error 1931. Setup cannot update the file C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\50\bin\FP5AUTL.DLL because it is protected by Windows. You may need to update your operating system for this program to work correctly. Contact Microsoft Product Support Services (PSS) for assistance.
  • Error 1931. Setup cannot update the file C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\50\bin\FPMMC.DLL because it is protected by Windows. You may need to update your operating system for this program to work correctly. Contact Microsoft Product Support Services (PSS) for assistance.
  • Error 1931. Setup cannot update the file C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\50\bin\CFGWIZ.EXE because it is protected by Windows. You may need to update your operating system for this program to work correctly. Contact Microsoft Product Support Services (PSS) for assistance.
Note If you have installed Windows Server 2003 Service Pack 1 (Sp1) on the computer, Office XP SP3 will try to update the Cfgwiz.exe file only. In this case, you will receive the last error message only.

↑ Back to the top


Cause

This problem may occur if the following conditions are true:
  • The files that are installed by FrontPage Server Extensions 2002 in the following location are updated by Office XP Service Pack 3:
    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\50\bin
  • These files are protected by the Windows File Protection (WFP) feature in Windows Server 2003 and Windows 2000 Server.
For more information about the Windows File Protection feature, click the following article number to view the article in the Microsoft Knowledge Base:
222193 Description of the Windows File Protection feature

↑ Back to the top


Workaround

To work around this problem, use one of the following methods:
  • Method 1:Click OK to close the error message dialog boxes that are described in the "Symptoms" section. The Office XP SP3 installation will continue, and it will complete successfully.
  • Method 2:To prevent the error message, run a silent installation of Office XP SP3. To do this, click Start, click Run, type the following command, and then click OK:
    Msiexec /p path\MAINSP3ff.MSP /qn /L*v C:\PatchLog.txt
    Note This quiet mode command line will not succeed if either Windows Installer 3.1.4000.1823 or Windows Server 2003 SP1 has been installed on the computer.

    To verify the version, check the file properties of the MSI.DLL file that is located in the C:\Windows\System32 folder. An update to the Windows Installer that will allow the command line to complete successfully is available from the following website:

↑ Back to the top


References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
832671 Description of Microsoft Office XP Service Pack 3

↑ Back to the top


Keywords: kberrmsg, kbprb, KB837827

↑ Back to the top

Article Info
Article ID : 837827
Revision : 5
Created on : 9/12/2011
Published on : 9/12/2011
Exists online : False
Views : 478