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The Microsoft Exchange Information Store service uses increasing amounts of virtual memory and eventually stops unexpectedly


View products that this article applies to.

Symptoms

On your Exchange computer, the Microsoft Exchange Information Store service (Store.exe) becomes unresponsive or stops unexpectedly. Additionally, a warning event that is similar to the following may be logged in the application event log:

Event Type: Error
Event Source: MSExchangeIS
Event Category: Performance
Event ID: 9582
Description: The virtual memory necessary to run your Exchange server is fragmented in such a way that performance may be affected. It is highly recommended that you restart all Exchange services to correct this issue.

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Cause

One possible cause of this behavior is MAPI client sessions holding messages open in the information store.

If a program or a service has more than 50 messages open, there may be a problem with the client program holding messages open in the information store. The program or the service that is holding messages open can be a user account or a service that is running on the server or on the client. An example of a service is a fax program or an antivirus program.

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Resolution

To resolve this issue, use one of the following methods:
  • Close the client program that is holding the messages open. This may be as simple as closing Microsoft Outlook, or it may require the removal of the software program that is causing the problem.
  • Restart the Microsoft Exchange Information Store service.
Note Both options will release the open messages in the information store.

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More information

To see if a client is holding messages open, use Exchange System Manager or Microsoft Exchange Administrator to view the number of messages that each client session has open.

Microsoft Exchange Server 2003

To view the number of messages that each client session has open in Exchange 2003, follow these steps:
  1. Click Start, point to All Programs, point to Microsoft Exchange, and then click System Manager.
  2. If administrative groups appear, expand Administrative Groups, and then expand First Administrative Group. If administrative groups do not appear, go to step 3.
  3. Expand Servers, expand your Exchange computer, expand First Storage Group, and then expand Mailbox Store.
  4. Click Logons, click the View menu, and then click Add/Remove Columns.
  5. In the Add/Remove Columns dialog box, click Open Messages, click Add, and then click OK.

Microsoft Exchange 2000 Server

To view the number of messages that each client session has open in Exchange 2000, follow these steps:
  1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
  2. If administrative groups appear, expand Administrative Groups, and then expand First Administrative Group. If administrative groups do not appear, go to step 3.
  3. Expand Servers, expand your Exchange computer, expand First Storage Group, and then expand Mailbox Store.
  4. Click Logons, click the View menu, and then click Choose Columns.
  5. In the Modify Columns dialog box, click Open Messages, click Add, and then click OK.

Microsoft Exchange Server 5.5

To view the number of messages that each client session has open in Exchange Server 5.5, follow these steps:
  1. Click Start, point to Programs, point to Microsoft Exchange, and then click Microsoft Exchange Administrator.
  2. Expand your site, and then expand Configuration.
  3. Expand Servers, expand your Exchange computer, and then expand Private Information Store.
  4. Click Logons, click the View menu, and then click Columns.
  5. In the Columns dialog box, click Open Messages, click Add, and then click OK
Note The Open Messages column is located on the far right in the right pane. You can click the column header to sort the number of open messages in ascending or descending order.

When you find that a client program is holding messages open, the probable cause is a software program that scans e-mail messages or a software program that modifies e-mail messages. Common applications that cause this kind of problem are antivirus programs or content management programs that are running on the client.

Note The information in this article describes how to recognize a problem with messages being held open by one or more MAPI sessions. You can limit the number of messages that any client on an Exchange computer can have open at the same time. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
289109 How to limit the number of messages opened for each MAPI logon

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Keywords: KB835408, kbprb, kbarchive, kbnosurvey

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Article Info
Article ID : 835408
Revision : 7
Created on : 1/11/2015
Published on : 1/11/2015
Exists online : False
Views : 289