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Exchange-related tasks are missing from the Active Directory Users and Computers snap-in


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Symptoms

When you start the Active Directory Users and Computers snap-in you find that the Microsoft Exchange-related tasks are missing. You may experience all the following symptoms:
  • When you right-click a user, the Exchange Tasks command does not appear on the shortcut menu. Therefore, you cannot start Exchange Task Wizard.
  • When you open the Properties page for a user, the Exchange Advanced tab, the Exchange Features tab, and the Exchange General tab do not appear.
  • When you use the LDP tool to open the Configuration container and then open the DisplaySpecifiers container, you find that there are no Exchange display specifiers, such as the msExchPFTree-Display display specifier.

    Note Display specifiers are objects that hold Active Directory user-interface (UI) information and provide a flexible UI mechanism to meet the requirements of the various user groups in the distributed network.

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Cause

This problem may occur if either of the following conditions is true:
  • The Microsoft Exchange System Management Tools are not installed on the computer. The Active Directory Users and Computers snap-in is available because you have installed the Microsoft Windows 2000 Server Administration Tools Pack (AdminPak.msi). However, to remotely administer a computer that is running Microsoft Exchange 2000 Server, you must also install the Microsoft Exchange System Management Tools.
  • The Maildsmx.dll file is not registered correctly. This problem may occur if you are using a non-English version of Exchange.

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Workaround

To work around this problem, install the Exchange System Management Tools on the computer. If the Exchange-related tasks still are not available, register the Maildsmx.dll file again.

To install the Exchange System Management Tools, follow these steps:
  1. Run the Exchange 2000 Setup program from the Exchange 2000 Server CD on the computer where you want to use the Exchange System Management Tools.
  2. When the Component Selection window appears in the wizard, click Microsoft Exchange 2000, and then change the installation option to Custom.
  3. Select Microsoft Exchange System Management Tools, and then select Install. Leave all other components at the default setting of None.
  4. Click OK to continue the installation.
After Exchange System Manager is installed, the Exchange-related tasks are available. If the Exchange-related tasks are still not available after the Exchange System Management Tools are installed, register the Maildsmx.dll file again. To do this, follow these steps:
  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. Type cd\program files\exchsrvr\bin at the command prompt.
  3. Type regsvr32 /i maildsmx.dll, and then press ENTER.

    This command repopulates the Exchange display specifiers.
Note By default, the Maildsmx.dll file is installed in the \Program Files\Exchsrvr\Bin folder.

Note You can also install the latest Exchange 2000 service pack to work around this issue. When you install the latest Exchange 2000 service pack, the new version of the Maildsmx.dll file is registered automatically.

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Keywords: KB834122, kbprb

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Article Info
Article ID : 834122
Revision : 3
Created on : 10/27/2006
Published on : 10/27/2006
Exists online : False
Views : 245