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Cannot add an additional mailbox to a MAPI profile in Exchange 2000 Server


View products that this article applies to.

Symptoms

When you try to add an additional Exchange mailbox to an existing MAPI profile, you receive one of the following error messages:
The name could not be resolved. The action could not be completed.

The name cannot be resolved. The action cannot be completed.
For example, this issue occurs after you follow these steps to add an additional mailbox to a MAPI profile:
  1. In Control Panel, double-click Mail, and then click Show Profiles.
  2. Click the profile that you want to modify, click Properties, click E-mail Accounts, and then click Next.
  3. In the Name list, click Microsoft Exchange Server, click Change, and then click More Settings.
  4. Click the Advanced tab, and then click Add.

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Cause

This issue may occur if another object that has the same LegacyExchangeDN attribute as the Exchange Server exists in the Active Directory directory service. This object may exist in the LostAndFoundConfig container container. In this scenario, the
101e6613
registry key is absent from the following registry subkey on the client computer where you cannot add an additional Exchange mailbox to the profile:
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\<username>\13dbb0c8aa05101a9bb000aa002fc45a

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Resolution

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

To search for this LegacyExchangeDN attribute in the directory, use the LDP utility against a Global Catalog.

Note The default port is 3268.

To do this, follow these steps:
  1. Open the ldp.exe tool.
  2. On the Browse menu, click Search.
  3. In the Filter field, paste the LegacyExchangeDN string of the impacted server:
    legacyExchangeDN=/o=OrganizationName/ou=AdministrativeGroupName/cn=Configuration/cn=Servers/cn=ServerName
  4. Set the Scope to the Subtree option, and then click Run.
  5. If the search returns two entries, you must investigate in the output, and determine which object has the same LegacyExchangeDN attribute as the Exchange server computer.
If an object that has the same name as the Exchange computer appears in the LostAndFoundConfig container, remove it. To do this, follow these steps:
  1. Start the ADSI Edit snap-in. To do this, click Start, click Run, type adsiedit.msc in the Open box, and then click OK.

    Note ADSI Edit is included with the Microsoft Windows 2000 Support Tools. For additional information about how to install the Windows 2000 Support Tools, click the following article number to view the article in the Microsoft Knowledge Base:
    301423� How to install the Windows 2000 Support Tools to a Windows 2000 Server-based computer
  2. Connect to a domain controller if you are not already connected to a domain controller.
  3. Expand Configuration Container [servername.example.com], expand CN=Configuration,DC=example,DC=com, and then click CN=LostAndFoundConfig.
  4. View the contents of the right pane. If an object that has the same name as the Exchange computer appears in the right pane, right-click that object, and then click Delete. Click Yes to confirm the removal of the object.
  5. Quit ADSI Edit.
  6. On the Exchange computer, restart all the Exchange-related services.

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Workaround

To work around this issue, copy the missing
101e6613
registry entry from a correctly functioning profile.

Note This workaround resolves the issue for the current user. However, you must perform this workaround every time that you create a new user.

To copy this registry value, follow these steps:

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows
  1. On the computer where you cannot add an additional Exchange mailbox to the profile, start Registry Editor. To do this, click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\<username>\13dbb0c8aa05101a9bb000aa002fc45a
    Note Replace <username> with the name of the user where you cannot successfully add a mailbox to the MAPI profile.
  3. If the
    101e6613
    registry entry does not appear in the right pane, create it. To do this, follow these steps:
    1. On the Edit menu, point to New, and then click Binary Value.
    2. In the New Value #1 box, type 101e6613, and then press ENTER.
  4. Copy the contents from the
    101e6613
    registry entry of a user where you can successfully add an additional mailbox to the user's MAPI profile to the new registry value that you created in step 3. To do this, follow these steps:
    1. Locate and then click the following registry subkey, where <username2> is the name of a user where you can successfully add a mailbox to the MAPI profile:
      HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\<username2>\13dbb0c8aa05101a9bb000aa002fc45a
    2. In the right pane, right-click 101e6613, and then click Modify.
    3. In the Value data box, select all the text, press CTRL+C to copy the text to the clipboard, and then click Cancel.
    4. Locate and then click the following registry subkey, where <username> is the name of a user where you cannot successfully add a mailbox to the MAPI profile:
      HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\<username>\13dbb0c8aa05101a9bb000aa002fc45a
    5. In the right pane, right-click 101e6613, and then click Modify.
    6. Press CTRL+V to paste the clipboard contents to the Value data box, and then click OK.
  5. Quit Registry Editor.

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Keywords: KB833399, kbprb, kberrmsg

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Article Info
Article ID : 833399
Revision : 3
Created on : 9/6/2011
Published on : 9/6/2011
Exists online : False
Views : 275