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The Exchange Server 2003 or the Exchange 2000 Server Setup program stops responding while replicating data from Exchange Server 5.5


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Symptoms

When you try to install Microsoft Exchange Server 2003 or Microsoft Exchange 2000 Server in an existing Microsoft Exchange Server version 5.5 site, the Setup program stops responding while replicating data from Exchange Server 5.5. You may receive an error message that is similar to one of the following:

Message 1

Setup failed while installing sub component site replication service with error code 0xC1030B11.

Message 2

Setup failed while installing sub-component Site Replication Services with error code 0xC1030B11 (please consult the Installation logs for a detailed description). You may cancel the installation or try the failed step again.
If you click Retry, the Setup program tries to reconnect to the Exchange Server 5.5 server. If you click Cancel, the messaging component of Exchange Server 2003 or Exchange 2000 Server is not installed. However, the rest of the installation process is completed.

You may see records that are similar to the following in the Exchange Server Setup Progress.log:

[17:10:36] Attempting to add a replica of naming context /o=ORGNAME/ou=SITENAME/cn=Microsoft DMD, from Server E2K3-SERVER to Server 5.5-SERVER
[17:11:21] Replication encountered a connection failure error.
[17:11:21] Replication encountered a recoverable error. About to sleep for 1 seconds.
[17:11:23] Attempting to add a replica of naming context /o=ORGNAME/ou=SITENAME/cn=Microsoft DMD, from Server E2K3-SERVER to Server 5.5-SERVER
[17:12:08] Replication encountered a connection failure error.
[17:12:08] Replication encountered a recoverable error. About to sleep for 3 seconds.
[17:12:11] Attempting to add a replica of naming context /o=ORGNAME/ou=SITENAME/cn=Microsoft DMD, from Server E2K3-SERVER to Server 5.5-SERVER
.
[17:29:08] Replication encountered a connection failure error.
[17:29:08] Replication encountered a recoverable error. About to sleep for 28 seconds.
[17:29:37] Attempting to add a replica of naming context /o=ORGNAME/ou=SITENAME/cn=Microsoft DMD, from Server E2K3-SERVER to Server 5.5-SERVER
[17:30:22] Replication encountered a connection failure error.
[17:30:22] Replication encountered a recoverable error. About to sleep for 30 seconds.
[17:30:52] Sc_dra_replica_add (f:\titanium\admin\src\libs\55dsinst\cdsinst.cxx:3912)
Error code 0XC1030B11 (2833): A connection could not be made to the remote directory service, possibly due to network failure. Be sure that both directory services are running and that your network is available, and then try connecting again.
[17:30:52] mode = 'Install' (61953) CBaseAtom::ScSetup (f:\titanium\admin\src\udog\setupbase\basecomp\baseatom.cxx:842)
Error code 0XC1030B11 (2833): A connection could not be made to the remote directory service, possibly due to network failure. Be sure that both directory services are running and that your network is available, and then try connecting again.

The Exchange Server Setup Progress.log file is located in the root folder of the boot partition.

If you permit the Setup program to finish, Exchange Services do not start, and two event messages that are similar to the following are logged in the application event log:

Message 1

Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 2059
Description: The DsProxy dll is required but cannot be loaded, error 'c00700cb'.

Message 2

Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 1005
Description: Unexpected error The system could not find the environment option that was entered. Facility: Win32 ID no: c00700cb Microsoft Exchange System Attendant occurred.

Note For the purposes of this article, both the following programs are referred to as Exchange 2000x:
  • Exchange Server 2003
  • Exchange 2000 Server

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Cause

This issue may occur if you have a networking problem between Exchange 200x and Exchange Server 5.5. One or more networking issues may exist, such as a host name resolution issue, a physical network connectivity issue, incorrect DNS (Domain Name System) settings, a Windows Internet Name Service (WINS) issue, an LMHOSTS file issue, or another similar issue.

Frequently, the cause of this issue is that the DNS settings on the computer that is running Exchange Server 5.5 are not configured correctly. You may find that the server is pointing to a DNS server on the Internet, or is pointing to an internal, non Microsoft Windows-based DNS that does not have a record for the Exchange 200x server. To verify whether DNS name resolution is working correctly, use the ping command from the Exchange Server 5.5 server to the Exchange 200x server to search for the fully qualified domain name (FQDN) of the Exchange 200x server. For example, follow these steps:
  1. On the computer that is running Exchange Server 5.5, click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type the following command, and then press ENTER:
    ping e2k3-server.example.com
Another common cause of this issue is that NetBIOS name resolution is not working. To verify whether NetBIOS name resolution is working correctly, use the ping command from the Exchange Server 5.5 server to the Exchange 200x server to search for the NetBIOS name of the Exchange 200x server. For example, follow these steps:
  1. On the computer that is running Exchange Server 5.5, click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type the following command, and then press ENTER:
    ping e2k3-server
Additionally, issue may occur if the logon account for the MS Exchange Directory Service is different on each Exchange server.

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Resolution

To troubleshoot this issue, follow the steps in each of the following three sections.

Verify that the Exchange Server 5.5 server is pointing to the correct DNS.

Verify that the Exchange Server 5.5 server is pointing to an internal DNS that has an A Record (HOST Record) for the Exchange 200x server. If you find that the DNS settings are not configured correctly on the Exchange Server 5.5 server, point the Exchange Server 5.5 server to an internal DNS that has a record for the Exchange 200x server. Generally, this will be the same DNS that the Exchange 200x server is pointing to for DNS.

If Exchange Server 5.5 is running on a computer that is running Microsoft Windows NT 4.0, you must restart the computer to make sure that the new DNS settings take effect. If Exchange Server 5.5 is running on a computer that is running Microsoft Windows 2000 or later, you must re-register the DNS settings. To do this, follow these steps:
  1. At a command prompt, type Ipconfig /registerdns, and then press ENTER.
  2. Restart the Netlogon service.

Troubleshoot the network connection between the two Exchange servers.

To troubleshoot network connection between the two Exchange servers, follow these steps:
  1. Use the ping command to ping from one server to the other by IP address.
  2. Use the ping command to ping from one server to the other by fully qualified domain name (FQDN).
  3. Use the NSLookup command to verify that you can query DNS. Make sure that the DNS server that is returned contains records for the Exchange Server 5.5 server that you are trying to replicate with.

Make sure that the logon account for the Microsoft Exchange Directory Service is the same for both Exchange servers.

Verify that the logon account and the password that is specified for the Microsoft Exchange Directory Service on then computer that is running Exchange 200x is the same as the logon account and the password that is specified for this service on the computer that is running Exchange Server 5.5.

If you change the logon account and the password of this service in Exchange 200x to the same logon account and the same password that the Exchange Server 5.5 service uses, the connection can be made and the Exchange 2003 Server Setup program can resume.

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More information

Typically, if you can correct this issue during the installation of Exchange Server 200x, the installation process will be completed successfully. If you complete the installation process without correcting this issue, the installation will not be correct and you must remove Exchange Server 200x before you can re-install Exchange Server 200x.

For more information about how to remove Exchange Server 2003 from your computer, click the following article number to view the article in the Microsoft Knowledge Base:
833396� How to remove Exchange Server 2003 from your computer

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Keywords: KB833395, kbbug, kbprb

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Article Info
Article ID : 833395
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 310